aboutsummaryrefslogtreecommitdiffstats
path: root/community/asio/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-16 08:50:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-16 08:50:46 +0000
commitf5bcb24db9fdce08492af30dfb17e38b0f7b7269 (patch)
tree40b227c49dfb29fa9c9633471a8d1a27d046bfb1 /community/asio/APKBUILD
parent67573823ca585743e2197f3245cbdfb8b20e7488 (diff)
community/asio: upgrade to 1.12.0
fixes #8662
Diffstat (limited to 'community/asio/APKBUILD')
-rw-r--r--community/asio/APKBUILD43
1 files changed, 13 insertions, 30 deletions
diff --git a/community/asio/APKBUILD b/community/asio/APKBUILD
index 9f8116678c5..09d65c474cf 100644
--- a/community/asio/APKBUILD
+++ b/community/asio/APKBUILD
@@ -1,56 +1,39 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=asio
-pkgver=1.10.6
+pkgver=1.12.0
_ver=${pkgver//./-}
-pkgrel=1
+pkgrel=0
pkgdesc="A cross-platform C++ library for network programming"
url="https://think-async.com"
arch="all"
license="BSL-1.0"
depends=""
depends_dev="boost-dev libressl-dev"
-makedepends="$depends_dev"
+makedepends="$depends_dev autoconf automake libtool"
install=""
subpackages="$pkgname-dev"
-source="http://downloads.sourceforge.net/project/asio/asio/${pkgver}%20%28Stable%29/asio-$pkgver.tar.bz2
- fix-strerror_r.patch
- libressl.patch
- "
+source="https://github.com/chriskohlhoff/asio/archive/asio-${pkgver//./-}.tar.gz"
-_builddir="$srcdir"/asio-$pkgver
+builddir="$srcdir"/asio-asio-${pkgver//./-}/asio
prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ cd "$builddir"
+ ./autogen.sh
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man \
- || return 1
- make || return 1
+ --enable-shared
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="85d014a356a6e004cd30ccd4c9b6a5c2 asio-1.10.6.tar.bz2
-dfc0d5d1c14ca0a247d835c944e400a6 fix-strerror_r.patch
-7b3d05cf45e59abc04a61549a401fb82 libressl.patch"
-sha256sums="e0d71c40a7b1f6c1334008fb279e7361b32a063e020efd21e40d9d8ff037195e asio-1.10.6.tar.bz2
-0b3eb6d74c9dd11e08368da0f9e09446e2383b5fc840e630581fef3672db95ac fix-strerror_r.patch
-6b78adbf094b956e2b3451cfd19a73b1f2c12a9a78a491d64819dd0276239991 libressl.patch"
-sha512sums="7146e75a378de57daab88e7ba509ae01367ffa0d7c4c90481e221977a6b9f4fd80e9caac5c6b4c27bc7652e44cd210e2c6cabf5681d7c62747df14bbc25e8c23 asio-1.10.6.tar.bz2
-a023e305a9efa6b93489374dfe9881c447d748a8d48ff803e0ac7ff1be618460b57de024e79da8c08dab4bcd214cbf2c3991d963eef678ca8dbd48b3c8933a70 fix-strerror_r.patch
-6caeb4748f1a68783e2da3f548f3a4f91e413d96ba3a508b8279f04a1fd1f73f8d5d53f1b2bb1accf2a15bd3056144fce64668bf06091550055d125aef2169b7 libressl.patch"
+sha512sums="a0e341fd6a848784e1533df84d1e6b361c8468f59d4fbde68c1500c1f8a2124ad78db0169098dbbc594ce26717eb9760f37af13cb288a549e2bda563eecf2be3 asio-1-12-0.tar.gz"