aboutsummaryrefslogtreecommitdiffstats
path: root/community/asterisk-chan-dongle/asterisk-14.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-12-21 16:40:40 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-12-21 16:40:40 +0200
commit837c58784f9717a3640a70f68bc001ea16d5ca4a (patch)
tree3255ab82ae51c713dc204ffe5c9d377bd26cba46 /community/asterisk-chan-dongle/asterisk-14.patch
parentc49e67b06aeba81a5c9154bf9e41b793d9e6608e (diff)
community/asterisk-chan-dongle: moved from testing
Diffstat (limited to 'community/asterisk-chan-dongle/asterisk-14.patch')
-rw-r--r--community/asterisk-chan-dongle/asterisk-14.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/asterisk-chan-dongle/asterisk-14.patch b/community/asterisk-chan-dongle/asterisk-14.patch
new file mode 100644
index 00000000000..49f20b765e7
--- /dev/null
+++ b/community/asterisk-chan-dongle/asterisk-14.patch
@@ -0,0 +1,35 @@
+diff -ru asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24.orig/Makefile.in asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24/Makefile.in
+--- asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24.orig/Makefile.in 2016-10-02 17:35:30.000000000 +0300
++++ asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24/Makefile.in 2016-11-11 15:29:54.789991216 +0200
+@@ -37,7 +37,7 @@
+ INSTALL = @INSTALL@
+ CHMOD = chmod
+
+-DEFS = -DASTERISK_VERSION_NUM=130000
++DEFS = -DASTERISK_VERSION_NUM=130000 -DAST_MODULE_SELF_SYM=self_module
+ CFLAGS = @CFLAGS@ -I$(srcdir) @CPPFLAGS@ $(DEFS) @DEFS@ @AC_CFLAGS@
+ LDFLAGS = @LDFLAGS@
+ SOLINK = @SOLINK@
+diff -ru asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24.orig/chan_dongle.c asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24/chan_dongle.c
+--- asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24.orig/chan_dongle.c 2016-10-02 17:35:30.000000000 +0300
++++ asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24/chan_dongle.c 2016-11-11 15:28:51.832489663 +0200
+@@ -39,10 +39,7 @@
+ #include <config.h>
+ #endif /* HAVE_CONFIG_H */
+
+-
+ #include <asterisk.h>
+-ASTERISK_FILE_VERSION(__FILE__, "$Rev: " PACKAGE_REVISION " $")
+-
+ #include <asterisk/ast_version.h>
+ #include <asterisk/stringfields.h> /* AST_DECLARE_STRING_FIELDS for asterisk/manager.h */
+ #include <asterisk/manager.h>
+@@ -1793,8 +1790,3 @@
+ );
+
+ //AST_MODULE_INFO_STANDARD (ASTERISK_GPL_KEY, MODULE_DESCRIPTION);
+-
+-EXPORT_DEF struct ast_module* self_module()
+-{
+- return ast_module_info->self;
+-}