aboutsummaryrefslogtreecommitdiffstats
path: root/community/audacity/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-03 07:46:34 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-05 15:44:44 +0000
commit4b307648ac5124d1298daff8ca1f12434d041228 (patch)
treeb8e661542a76514c533318f5edeef2b99dfffd1f /community/audacity/APKBUILD
parentfaf3d9eaa18b2d6671c4fcbe7175763df52b5b60 (diff)
community/audacity: upgrade to 2.3.2
Diffstat (limited to 'community/audacity/APKBUILD')
-rw-r--r--community/audacity/APKBUILD83
1 files changed, 37 insertions, 46 deletions
diff --git a/community/audacity/APKBUILD b/community/audacity/APKBUILD
index 23aa2168d53..9f36f311310 100644
--- a/community/audacity/APKBUILD
+++ b/community/audacity/APKBUILD
@@ -1,13 +1,13 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=audacity
-pkgver=2.1.1
-pkgrel=1
+pkgver=2.3.2
+pkgrel=0
pkgdesc="Multitrack audio editor"
-url="http://audacity.sourceforge.net"
+url="https://www.audacityteam.org/"
arch="all"
-license="GPL-2.0"
-makedepends="$depends_dev
+license="GPL-2.0-or-later"
+makedepends="
alsa-lib-dev
bash
expat-dev
@@ -19,67 +19,58 @@ makedepends="$depends_dev
libogg-dev
libsndfile-dev
libvorbis-dev
- portaudio-dev
soundtouch-dev
soxr-dev
taglib-dev
- wxgtk2.8-dev
+ wxgtk3-dev
+ ffmpeg-dev
+ automake
+ autoconf
+ libtool
"
-
subpackages="$pkgname-doc $pkgname-lang"
source="https://github.com/audacity/audacity/archive/Audacity-$pkgver.tar.gz
- musl-workaround.patch
- filedialog.patch
"
builddir="$srcdir"/audacity-Audacity-$pkgver
+prepare() {
+ default_prepare
+ autoreconf -fi
+}
+
build() {
local _arch
- cd "$builddir"
-
case "$CTARGET" in
- x86|x86_64) _arch="--enable-sse";;
- *) _arch="--disable-sse";;
+ x86|x86_64) _arch="--enable-sse";;
+ *) _arch="--disable-sse";;
esac
- export CXXFLAGS="$CXXFLAGS -std=gnu++98"
- LIBNYQUIST_USE_LOCAL=yes \
- CFLAGS="$CFLAGS -fPIC" \
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --with-expat=system \
- --with-lib-preference=system \
- --with-libsndfile=system \
- --with-libflac=system \
- --with-coundtouch=system \
- --with-soxr=system \
- --with-id3tag=system \
- --with-libvorbis=system \
- --with-portaudio=system \
- --with-libmad=system \
- --with-widgetextra=local \
- --without-libresample \
- --without-libsamplerate \
- --without-ffmpeg \
- --enable-nyquist \
- $_arch
- for i in ffmpeg libsoxr libvamp portaudio-v19; do
- rm -r lib-src/$i
- done
+ WX_CONFIG=wx-config-gtk3 \
+ bash configure \
+ --prefix="/usr" \
+ --with-libsndfile="system" \
+ --with-ffmpeg="system" \
+ --with-expat="system" \
+ --with-lame="system" \
+ --with-libsoxr="system" \
+ --with-portaudio \
+ --with-portmidi \
+ --with-libflac \
+ --with-libid3tag \
+ --with-libsamplerate \
+ --with-sbsms \
+ --with-soundtouch \
+ --with-libtwolame \
+ --with-libvorbis \
+ --without-lv2 \
+ $_arch
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="00b0a037ffefb670e7148414224c60330c4fb915a892cb635537caeba82815d0113c5bb07f7b2805ed9b42a1a75106ef6fdc2f1602fd5042c48cc5e111a34ffb Audacity-2.1.1.tar.gz
-b5488a7f5398c07fe986e090b8d61353ecba594ed23fda6a4444e59718f7d1e8bd5c716047ce139350983d5609b5810362a78a2fd5d85e9b1730d196c57c685b musl-workaround.patch
-7f10b5f53ada9faa7ad887400a5729a41228f8970ee4cc045291e9b203a9f7f068b09f709e23f7f2a15724acf82ed0e4bccfd163b2232b430d2c89b86ccc2751 filedialog.patch"
+sha512sums="a59d6e9e974d5f78f5ca561e3bea31fc1b3e88f9ea60b2df7ce8bcec264d886f3fdc8f20030e11a86daff8ffeb735850b5e5f73c45fbef0bfcc58692423e7cd0 Audacity-2.3.2.tar.gz"