aboutsummaryrefslogtreecommitdiffstats
path: root/community/bam/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-02 15:29:05 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-11-02 15:41:31 +0200
commit1a10c24e73376bce82d24f506833033b2288850a (patch)
tree4ae6e9508b3bf3efccb68a6a1d1490c58e1c5079 /community/bam/APKBUILD
parentcb2efe169ce7e9b186cf0a127393933c32782b87 (diff)
community/{bam, teeworlds}: move from main
Diffstat (limited to 'community/bam/APKBUILD')
-rw-r--r--community/bam/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/bam/APKBUILD b/community/bam/APKBUILD
new file mode 100644
index 00000000000..e48d74f2c00
--- /dev/null
+++ b/community/bam/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=bam
+#teeworlds is sole user of bam, and requires 0.4.x currently
+pkgver=0.4.0
+pkgrel=0
+pkgdesc='Fast and flexible build system using Lua'
+arch=all
+url=http://github.com/matricks/bam
+license='ZLIB'
+
+#source="$pkgname-$pkgver.tar.gz::https://github.com/matricks/bam/archive/v$pkgver.tar.gz"
+source="https://downloads.teeworlds.com/bam-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ sh make_unix.sh || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ install -Dm755 bam "$pkgdir"/usr/bin/bam || return 1
+ install -Dm755 license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE \
+ || return 1
+}
+
+md5sums="2f8e8336b8884110e8a355b12c9fa58a bam-0.4.0.tar.gz"
+sha256sums="5e4e4920b4d265da582f66774e9b1ec8ddfbe75ddc028fba86c12f686ea18db3 bam-0.4.0.tar.gz"
+sha512sums="c599cdf3618d317a5d304febd2e59d1116fc5819cdaf49969fdc25f88ed8f3e25831861c0c7fea05059d8af7085b654a7732bd89086bc166661b932d168ee2ca bam-0.4.0.tar.gz"