aboutsummaryrefslogtreecommitdiffstats
path: root/community/biber/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-12-15 13:02:24 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-12-15 13:02:40 +0000
commit7519612f9dbb60de528c5dd53ac29ae35842db76 (patch)
tree6e06aad5f59756b4cc71990ea63c387adf1e2d10 /community/biber/APKBUILD
parent3e7ede6b97ef15f35d55a879ffcf1c60e0aeb10e (diff)
community/biber: re-enabled test, minor APKBUILD changed according with the linter
Diffstat (limited to 'community/biber/APKBUILD')
-rw-r--r--community/biber/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/community/biber/APKBUILD b/community/biber/APKBUILD
index dfe0d2a7fdd..573144340e4 100644
--- a/community/biber/APKBUILD
+++ b/community/biber/APKBUILD
@@ -3,7 +3,7 @@
pkgname=biber
# This version should be compatible with Biblatex in testing
pkgver=2.14
-pkgrel=1
+pkgrel=2
pkgdesc="Backend processor for BibLaTeX"
url="https://github.com/plk/biber"
arch="noarch"
@@ -21,22 +21,19 @@ depends="perl perl-module-build perl-config-autoconf
perl-datetime-calendar-julian perl-datetime-format-builder perl-sort-key
perl-text-csv perl-text-csv_xs perl-list-moreutils-xs perl-perlio-utf8_strict perl-file-slurper
perl-parse-recdescent perl-io-string perl-mime-charset perl-namespace-autoclean"
-options="!check" # some of the test fails
checkdepends="perl-test-simple"
makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/plk/biber/archive/v${pkgver}.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/plk/biber/archive/v$pkgver.tar.gz"
prepare() {
default_prepare
- cd "$builddir"
# Disable long year tests on 32 bit
case "$CARCH" in arm*|mips|mipsel*|x86)
sed -i '/17000002/ s+.*+eq_or_diff("dummy", "dummy", "skip 32 bit");+' t/dateformats.t
;;
esac
-
+
case "$CARCH" in arm*|x86)
sed -i -e '7s/47/41/' t/dateformats.t
sed -i -e '882s/.*/#&/' t/dateformats.t
@@ -51,18 +48,15 @@ prepare() {
}
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
./Build
}
-#check() {
-# cd "$builddir"
-# ./Build test
-#}
+check() {
+ ./Build test
+}
package() {
- cd "$builddir"
./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}