aboutsummaryrefslogtreecommitdiffstats
path: root/community/binaryen
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-11 21:29:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-12 15:16:35 -0300
commit01167866dbf959b2f437ac128474398baf1c5636 (patch)
treec6fdac2bc7dbf25e8ca6d58ea8badbeeff34729d /community/binaryen
parent9be6593103fba1c86e278636787911c4db398ad4 (diff)
community/binaryen: drop tests since they require python2
Diffstat (limited to 'community/binaryen')
-rw-r--r--community/binaryen/APKBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/community/binaryen/APKBUILD b/community/binaryen/APKBUILD
index c647fd02d64..2efaab5b604 100644
--- a/community/binaryen/APKBUILD
+++ b/community/binaryen/APKBUILD
@@ -4,13 +4,14 @@ pkgname=binaryen
pkgver=40
pkgrel=0
pkgdesc="Compiler infrastructure and toolchain library for WebAssembly, in C++"
+options="!check" # Tests require python2
url="https://github.com/WebAssembly/binaryen"
arch="all !s390x"
license="Apache-2.0"
makedepends="cmake"
-checkdepends="nodejs python2"
+checkdepends="nodejs" # python2"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/WebAssembly/$pkgname/archive/version_$pkgver.tar.gz
+source="binaryen-$pkgver.tar.gz::https://github.com/WebAssembly/binaryen/archive/version_$pkgver.tar.gz
link-dynamically.patch
ignore-type-limits-error.patch
fix-gcc8-wcatch-value.patch
@@ -22,8 +23,6 @@ case "$CARCH" in
esac
build() {
- cd "$builddir"
-
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -36,16 +35,12 @@ build() {
}
check() {
- cd "$builddir"
-
# waterfall requires additional dependency
# gcc-tests fail, dunno why
python2 check.py --no-test-waterfall --no-run-gcc-tests
}
package() {
- cd "$builddir"
-
make install DESTDIR="$pkgdir"
rm "$pkgdir"/usr/share/binaryen/binaryen.js
}