aboutsummaryrefslogtreecommitdiffstats
path: root/community/binaryen
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-21 12:35:31 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-21 12:36:44 +0200
commitdfe3d6d4ef27a3c3205bcb49e3b88db8684872e5 (patch)
treebde62561f5b638760e6ab2e2608426bbedefe7ce /community/binaryen
parenteb21fafa038fecca800661fc3e19713088cc36c8 (diff)
community/binaryen: fix build on aarch64, armhf and ppc64le
This fix is just a temporary workaround! See https://github.com/WebAssembly/binaryen/issues/1059
Diffstat (limited to 'community/binaryen')
-rw-r--r--community/binaryen/APKBUILD6
-rw-r--r--community/binaryen/ignore-type-limits-error.patch11
2 files changed, 15 insertions, 2 deletions
diff --git a/community/binaryen/APKBUILD b/community/binaryen/APKBUILD
index 9f0dfdff055..54d2ee16d24 100644
--- a/community/binaryen/APKBUILD
+++ b/community/binaryen/APKBUILD
@@ -11,7 +11,8 @@ makedepends="cmake"
checkdepends="nodejs python2"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/WebAssembly/$pkgname/archive/$pkgver.tar.gz
- link-dynamically.patch"
+ link-dynamically.patch
+ ignore-type-limits-error.patch"
builddir="$srcdir/$pkgname-$pkgver"
case "$CARCH" in
@@ -48,4 +49,5 @@ package() {
}
sha512sums="420a79020fdbf9e79ac55441c27839db5a55c5ce4ace21f289bb2e6a96bde79f47b93097a570f5ace8b80837c51b91c115727283b9d11731120749f6e107dd5b binaryen-1.37.14.tar.gz
-4a6f6708b8d72ba0be901eb0a6cba4e07e40270fc1d5abf5bea5f82ef34100ecb2017a1c8ae1c4b10446ef87d0328f4b4f9a7776ec8c2f850170fe241cfda1c6 link-dynamically.patch"
+4a6f6708b8d72ba0be901eb0a6cba4e07e40270fc1d5abf5bea5f82ef34100ecb2017a1c8ae1c4b10446ef87d0328f4b4f9a7776ec8c2f850170fe241cfda1c6 link-dynamically.patch
+3b95a197cd8805dfa714cf9f31adc1437b6d29bd4082f752c16d98c40cd024b110c02a412285c78251cb5d0b3080c0f9e4d45d8dd0166c71b9462b1610191ab8 ignore-type-limits-error.patch"
diff --git a/community/binaryen/ignore-type-limits-error.patch b/community/binaryen/ignore-type-limits-error.patch
new file mode 100644
index 00000000000..a18a137cfb8
--- /dev/null
+++ b/community/binaryen/ignore-type-limits-error.patch
@@ -0,0 +1,11 @@
+This is a temporary workaround for https://github.com/WebAssembly/binaryen/issues/1059.
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -150,6 +150,7 @@
+ endif ()
+ ADD_COMPILE_FLAG("-Wall")
+ ADD_COMPILE_FLAG("-Werror")
++ ADD_COMPILE_FLAG("-Wno-error=type-limits")
+ ADD_COMPILE_FLAG("-Wextra")
+ ADD_COMPILE_FLAG("-Wno-unused-parameter")
+ ADD_COMPILE_FLAG("-fno-omit-frame-pointer")