aboutsummaryrefslogtreecommitdiffstats
path: root/community/bitchx
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-01 10:52:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:13 +0000
commitcb13c3f7853b9cd853743ae4ab9eaa009ddc4aad (patch)
treed422bf9a18a4a633ee4ce3f00ea649d5cf3e1519 /community/bitchx
parentaa43f31f02bf427d74c3182677dd6ceb92053e5f (diff)
community/bitchx: rebuild against openssl 1.1
Diffstat (limited to 'community/bitchx')
-rw-r--r--community/bitchx/APKBUILD35
-rw-r--r--community/bitchx/fix-inline.patch31
-rw-r--r--community/bitchx/openssl-1.1.patch15
3 files changed, 60 insertions, 21 deletions
diff --git a/community/bitchx/APKBUILD b/community/bitchx/APKBUILD
index f4716392473..313968e7111 100644
--- a/community/bitchx/APKBUILD
+++ b/community/bitchx/APKBUILD
@@ -2,32 +2,26 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=bitchx
pkgver=1.2.1
-pkgrel=8
+pkgrel=9
pkgdesc="An IRC client"
url="http://www.bitchx.org/"
arch="all"
license="BSD"
-depends=""
-depends_dev="tcl-dev libressl-dev ncurses-dev"
-makedepends="$depends_dev coreutils"
-install=""
+makedepends="tcl-dev openssl-dev ncurses-dev coreutils automake autoconf libtool"
subpackages="$pkgname-doc"
source="https://downloads.sourceforge.net/project/bitchx/ircii-pana/bitchx-$pkgver/bitchx-$pkgver.tar.gz
+ fix-inline.patch
+ openssl-1.1.patch
"
-_builddir="$srcdir"/bitchx-$pkgver
+builddir="$srcdir"/bitchx-$pkgver
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare
+ autoreconf -vif
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -38,16 +32,15 @@ build() {
--localstatedir=/var \
--with-ssl \
--enable-ipv6 \
- --with-plugins \
- || return 1
- make || return 1
+ --with-plugins
+ make
}
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="4da13a2dcfa17847168e50e62be4f67a bitchx-1.2.1.tar.gz"
-sha256sums="2d270500dd42b5e2b191980d584f6587ca8a0dbda26b35ce7fadb519f53c83e2 bitchx-1.2.1.tar.gz"
-sha512sums="d5e0a151c69a85cca2544db8478af9fbd8fca17f882993fab7f898a95221087bf6219ad2144caedecb5bc508dfa02fa724737c615fbda47aeb8df8298cdfd645 bitchx-1.2.1.tar.gz"
+sha512sums="d5e0a151c69a85cca2544db8478af9fbd8fca17f882993fab7f898a95221087bf6219ad2144caedecb5bc508dfa02fa724737c615fbda47aeb8df8298cdfd645 bitchx-1.2.1.tar.gz
+39398c5cec2621971ee8ad2ee011fb99eaa43655350b346df7de9c3fa74ace4b7caf07953618180160e93f9769bbbd143d942c57599b8ac6a082d60d48ab4672 fix-inline.patch
+64e13d841ce0699ad419716a4b1404bab5961409cccea10f6dc46bb38e160aa62e1c2b8993e984ee2be681a951e29cf5d7c5f54ad232a20d6ed6ba11cda7dd2d openssl-1.1.patch"
diff --git a/community/bitchx/fix-inline.patch b/community/bitchx/fix-inline.patch
new file mode 100644
index 00000000000..813b1f549e1
--- /dev/null
+++ b/community/bitchx/fix-inline.patch
@@ -0,0 +1,31 @@
+diff --git a/source/expr2.c b/source/expr2.c
+index 8130919..b6c1aef 100644
+--- a/source/expr2.c
++++ b/source/expr2.c
+@@ -1192,7 +1192,7 @@ int lexerr (expr_info *c, char *format, ...)
+ * case 'operand' is set to 1. When an operand is lexed, then the next token
+ * is expected to be a binary operator, so 'operand' is set to 0.
+ */
+-__inline int check_implied_arg (expr_info *c)
++__inline static int check_implied_arg (expr_info *c)
+ {
+ if (c->operand == 2)
+ {
+@@ -1205,7 +1205,7 @@ __inline int check_implied_arg (expr_info *c)
+ return c->operand;
+ }
+
+-__inline TOKEN operator (expr_info *c, char *x, int y, TOKEN z)
++__inline static TOKEN operator (expr_info *c, char *x, int y, TOKEN z)
+ {
+ check_implied_arg(c);
+ if (c->operand)
+@@ -1216,7 +1216,7 @@ __inline TOKEN operator (expr_info *c, char *x, int y, TOKEN z)
+ return z;
+ }
+
+-__inline TOKEN unary (expr_info *c, char *x, int y, TOKEN z)
++__inline static TOKEN unary (expr_info *c, char *x, int y, TOKEN z)
+ {
+ if (!c->operand)
+ return lexerr(c, "An operator (%s) was found where "
diff --git a/community/bitchx/openssl-1.1.patch b/community/bitchx/openssl-1.1.patch
new file mode 100644
index 00000000000..d30e5a35b84
--- /dev/null
+++ b/community/bitchx/openssl-1.1.patch
@@ -0,0 +1,15 @@
+diff --git a/configure.in b/configure.in
+index 467395d..c27c8fe 100644
+--- a/configure.in
++++ b/configure.in
+@@ -566,8 +566,8 @@ case "$with_ssl" in
+ esac
+ case "$with_ssl" in
+ yes|check)
+- AC_CHECK_LIB([crypto], [SSLeay], [], [], [])
+- if test x"$ac_cv_lib_crypto_SSLeay" = x"yes"; then
++ AC_CHECK_LIB([crypto], [ERR_get_error], [], [], [])
++ if test x"$ac_cv_lib_crypto_ERR_get_error" = x"yes"; then
+ AC_CHECK_LIB([ssl], [SSL_accept], [], [], [])
+ fi
+ if test x"$ac_cv_lib_ssl_SSL_accept" = x"yes"; then