aboutsummaryrefslogtreecommitdiffstats
path: root/community/cassandra-cpp-driver
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-31 19:04:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:13 +0000
commitb3475ce8aebe413befd42e925e81a9fb121194cd (patch)
tree69b0a0a89c4d286b571b2961d80543196bd01ada /community/cassandra-cpp-driver
parentebfd807abea5bc14abefb3ea8cb888ec261ab9bb (diff)
community/cassandra-cpp-driver: upgrade to 2.10.0
Diffstat (limited to 'community/cassandra-cpp-driver')
-rw-r--r--community/cassandra-cpp-driver/APKBUILD12
-rw-r--r--community/cassandra-cpp-driver/libressl_fix.patch20
-rw-r--r--community/cassandra-cpp-driver/libuv-1.21-compat.patch25
3 files changed, 4 insertions, 53 deletions
diff --git a/community/cassandra-cpp-driver/APKBUILD b/community/cassandra-cpp-driver/APKBUILD
index d7e7ddcebf1..287ed72fc19 100644
--- a/community/cassandra-cpp-driver/APKBUILD
+++ b/community/cassandra-cpp-driver/APKBUILD
@@ -2,19 +2,17 @@
# Maintainer: Gennady Feldman <gena01@gmail.com>
pkgname=cassandra-cpp-driver
_pkgname=cpp-driver
-pkgver=2.9.0
-pkgrel=1
+pkgver=2.10.0
+pkgrel=0
pkgdesc="Cassandra CPP Driver"
url="https://datastax.github.io/cpp-driver/"
arch="x86_64 x86 ppc64le"
license="Apache-2.0"
options="!check" # FIXME: cassandra_integration_tests won't link
depends=""
-makedepends="cmake make libressl-dev libuv-dev"
+makedepends="cmake make openssl-dev libuv-dev"
subpackages="$pkgname-dev"
source="$_pkgname-$pkgver.tar.gz::https://github.com/datastax/cpp-driver/archive/$pkgver.tar.gz
- libuv-1.21-compat.patch
- libressl_fix.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -34,6 +32,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="45c6d58b1d287d142c9d7d6b1e28114683648a3634f44b185208fa44da64d4c8a9d485b3956a0cf7429e96f74faa588de832de30265dfa17782ca90e8163a0c1 cpp-driver-2.9.0.tar.gz
-5932f13a666b95a40d938f2cc6f3b6eb2107d5d569ff67be470913275816109f7a32426cf1e39ef950b9ba1c7f78063c388805b4106368f9f1527ff15c422241 libuv-1.21-compat.patch
-98814f9cb6b19830ffd35cbba00c22699a068c383358c798a777b1fbaa8d8d07eebe2c0d152635719168549cbc3d3fec3d2a64d0da1da333f3e7342708df1131 libressl_fix.patch"
+sha512sums="92e214a5e2358955999dc58caccc66483676ac274c10703bcd628c144190d6e878418fe9471672db726508fba33611c930526710ffe6ec583f4f54d5b9d280d9 cpp-driver-2.10.0.tar.gz"
diff --git a/community/cassandra-cpp-driver/libressl_fix.patch b/community/cassandra-cpp-driver/libressl_fix.patch
deleted file mode 100644
index 0a2e8227282..00000000000
--- a/community/cassandra-cpp-driver/libressl_fix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- cpp-driver-2.9.0/src/ssl/ssl_openssl_impl.cpp.orig
-+++ cpp-driver-2.9.0/src/ssl/ssl_openssl_impl.cpp
-@@ -113,7 +113,7 @@
- return len;
- }
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- static uv_rwlock_t* crypto_locks;
-
- static void crypto_locking_callback(int mode, int n, const char* file, int line) {
-@@ -597,7 +597,7 @@
- SSL_load_error_strings();
- OpenSSL_add_all_algorithms();
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- // We have to set the lock/id callbacks for use of OpenSSL thread safety.
- // It's not clear what's thread-safe in OpenSSL. Writing/Reading to
- // a single "SSL" object is NOT and we don't do that, but we do create multiple
diff --git a/community/cassandra-cpp-driver/libuv-1.21-compat.patch b/community/cassandra-cpp-driver/libuv-1.21-compat.patch
deleted file mode 100644
index f2070c985e5..00000000000
--- a/community/cassandra-cpp-driver/libuv-1.21-compat.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 0edf3d2eff88d7594ed7dc070f889b1bcacb677f Mon Sep 17 00:00:00 2001
-From: "Tobias C. Berner" <tcberner@FreeBSD.org>
-Date: Sun, 24 Jun 2018 08:25:53 +0200
-Subject: [PATCH] CPP-616 - Use uv/version.h as version file for libuv v1.21.0+
-
-libuv v1.21.0+ changed where the version file is located.
-
-Patch-Source: https://github.com/datastax/cpp-driver/commit/0edf3d2eff88d7594ed7dc070f889b1bcacb677f
----
- cmake/modules/CppDriver.cmake | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/cmake/modules/CppDriver.cmake b/cmake/modules/CppDriver.cmake
-index 92c243d5..098374f9 100644
---- a/cmake/modules/CppDriver.cmake
-+++ b/cmake/modules/CppDriver.cmake
-@@ -372,6 +372,8 @@ macro(CassUseLibuv)
-
- if (EXISTS "${LIBUV_INCLUDE_DIR}/uv-version.h")
- set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv-version.h")
-+ elseif (EXISTS "${LIBUV_INCLUDE_DIR}/uv/version.h")
-+ set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv/version.h")
- else()
- set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv.h")
- endif()