aboutsummaryrefslogtreecommitdiffstats
path: root/community/cesnet-tcs-cli
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-05-09 15:07:20 +0200
committerJakub Jirutka <jakub@jirutka.cz>2019-05-09 15:07:20 +0200
commit1e6a7184f6c3625dae556942e76f05d55ec1a094 (patch)
treed433755b74f1762613b98d09fc0ff2616b366d37 /community/cesnet-tcs-cli
parentedf67f32162cae8aa4c0d92eda717fce9203acd8 (diff)
community/cesnet-tcs-cli: move from testing
Diffstat (limited to 'community/cesnet-tcs-cli')
-rw-r--r--community/cesnet-tcs-cli/APKBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/community/cesnet-tcs-cli/APKBUILD b/community/cesnet-tcs-cli/APKBUILD
new file mode 100644
index 00000000000..319c1daf5f6
--- /dev/null
+++ b/community/cesnet-tcs-cli/APKBUILD
@@ -0,0 +1,19 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=cesnet-tcs-cli
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Client utility for CESNET TCS API"
+url="https://github.com/jirutka/cesnet-tcs-cli"
+arch="noarch"
+license="MIT"
+depends="ca-certificates curl openssl"
+options="!check" # no tests provided
+source="https://github.com/jirutka/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ make install DESTDIR="$pkgdir" prefix=/usr
+}
+
+sha512sums="5adf235b2817e2473e09224cfdd879f881d6830f09e6ce5306017d78216469bae02dd1b8e3852eb13dc65f79b3352c13c1f17b4cdcab1b0e68e7ed3096dfb14b cesnet-tcs-cli-0.1.0.tar.gz"