aboutsummaryrefslogtreecommitdiffstats
path: root/community/check_postgres
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-31 23:23:21 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-10-31 23:25:34 +0100
commitf2367ebad307851f39a41d9392e1a8dde5cbc49f (patch)
treec01aa116f44bc72e3d3f6c24ff4fa0fe4f92ecdf /community/check_postgres
parent41aad991c4e65c8b9d037dec9894e65a6d81c5f1 (diff)
community/check_postgres: move from testing
Diffstat (limited to 'community/check_postgres')
-rw-r--r--community/check_postgres/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/check_postgres/APKBUILD b/community/check_postgres/APKBUILD
new file mode 100644
index 00000000000..ac9981d64ae
--- /dev/null
+++ b/community/check_postgres/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: G.J.R. Timmer <gjr.timmer@gmail.com>
+# Maintainer: G.J.R. Timmer <gjr.timmer@gmail.com>
+# TODO: run tests!
+pkgname=check_postgres
+pkgver=2.23.0
+pkgrel=0
+pkgdesc="PostgreSQL monitoring script"
+url="https://bucardo.org/wiki/Check_postgres"
+arch="noarch"
+license="BSD"
+depends="postgresql perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/bucardo/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ perl Makefile.PL \
+ INSTALL_BASE=/usr \
+ INSTALLMAN1DIR=/usr/share/man/man1 \
+ INSTALLSITEMAN1DIR=/usr/share/man/man1 \
+ INSTALLMAN3DIR=/usr/share/man/man3 \
+ INSTALLSITEMAN3DIR=/usr/share/man/man3
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+
+ # Fix file extension because MakeMaker cannot do this
+ mv "$pkgdir"/usr/bin/check_postgres.pl "$pkgdir"/usr/bin/check_postgres
+}
+
+sha512sums="f00dc78acb4b4a30f85fa03cdac79fda53347840eb7835ac6cb6eb69ffe78eea90bde6f0372b37863d0770015d5358e3d14eeb1a4a27948c56cff059d281ded9 check_postgres-2.23.0.tar.gz"