aboutsummaryrefslogtreecommitdiffstats
path: root/community/chromium
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-07-06 10:34:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-06 10:35:04 +0000
commite6b78664b835a3623a00d27566a6e23f381f7411 (patch)
treef807cb0051e8de7d5fc9da7825d49347b613704a /community/chromium
parentaee2d34d81286e67d9abf245d08f42edc47eca62 (diff)
community/chromium: upgrade to 59.0.3071.115
Diffstat (limited to 'community/chromium')
-rw-r--r--community/chromium/APKBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index b4666dadf7e..9019be2a43d 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=chromium
-pkgver=59.0.3071.86
+pkgver=59.0.3071.115
pkgrel=0
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
@@ -76,6 +76,7 @@ install=""
options=suid
subpackages="$pkgname-doc $pkgname-chromedriver"
source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
+ pstables-2.8.h::http://git.savannah.gnu.org/cgit/freetype/freetype2.git/plain/src/psnames/pstables.h?h=VER-2-8
chromium-launcher.sh
chromium.conf
chromium.desktop
@@ -147,6 +148,7 @@ build() {
libwebp
libxml
libxslt
+ re2
snappy
yasm
"
@@ -159,6 +161,14 @@ build() {
-delete
done
+ # pdfium uses internal headers in freetype
+ # we copy from freetype sources
+ # https://bugs.chromium.org/p/pdfium/issues/detail?id=733
+ # should be fixed in freetype:
+ # https://savannah.nongnu.org/bugs/index.php?51156
+ mkdir -p "third_party/freetype/src/src/psnames/"
+ cp "$srcdir"/pstables-2.8.h third_party/freetype/src/src/psnames/pstables.h
+
# Work around bug in v8 in which GCC 6 optimizes away null pointer checks
# https://bugs.chromium.org/p/v8/issues/detail?id=3782
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69234
@@ -350,7 +360,8 @@ chromedriver() {
mv "$pkgdir"/usr/bin/chromedriver "$subpkgdir"/usr/bin || return 1
}
-sha512sums="1b92956435dcc422f3edf0ccd031007a19d291620d5af284ac2c1d2578b8524691713927b47130d2fd7c9acb7d9cd0376e9f5e3821b5feece7529b8b7bddf193 chromium-59.0.3071.86.tar.xz
+sha512sums="f30d54dedd43ba11321db1bcd443bb44a550ffca24ebb579727b98a15b6a3f6f598f20f0ef0889eab6820e6faacba0aa567927fd36d5ed0e61d7bd4f760e9993 chromium-59.0.3071.115.tar.xz
+a3bb959c65944ae2fb765725cedcffd743a58bc0c2cd1f1999d15fe79801d00f3474b08b4ed7b48859ed921eb57093d0ad09d90f201d729ed9b8a419a591ed29 pstables-2.8.h
b9a810416dd7a8ffc3a5ced85ad9acebda1665bd08a57eec7b189698cc5f74d2c3fd69044e20fcb83297a43214b2772a1312b2c6122ea0eb716abacf39524d60 chromium-launcher.sh
f6d962b9e4c22dd42183df3db5d3202dab33eccecafb1bf63ca678147289581262db1e5e64cbe8f9c212beefb0a6717bb8d311e497f56b55fe95b8bab2db493f chromium.conf
e182c998a43d22d1c76a86c561619afd1fca8c2be668265ad5e2f81a3806f7a154272cc027a2f8b370fb69446892c69e5967a4be76082325c14245ee7915234c chromium.desktop