aboutsummaryrefslogtreecommitdiffstats
path: root/community/cloudi/APKBUILD
diff options
context:
space:
mode:
authorMichael Truog <mjtruog@protonmail.com>2021-03-10 17:16:24 -0800
committerLeo <thinkabit.ukim@gmail.com>2021-03-13 22:02:07 +0000
commit6c67707673f2debef57024fc00fc9181eb1d57ad (patch)
tree659e2791ae709cbcb82072644e03c77cef7fe36b /community/cloudi/APKBUILD
parent367e05a111f375c144011d666b273fa2233d6087 (diff)
community/cloudi: enable ocaml support on x86/arm
* set GO111MODULE=auto for go1.16 usage with cloudi 2.0.1 * add small patch for ocaml 32-bit compilation of test
Diffstat (limited to 'community/cloudi/APKBUILD')
-rw-r--r--community/cloudi/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/cloudi/APKBUILD b/community/cloudi/APKBUILD
index 29ea1f09412..627d0dcd5aa 100644
--- a/community/cloudi/APKBUILD
+++ b/community/cloudi/APKBUILD
@@ -29,7 +29,7 @@
pkgname=cloudi
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Cloud computing framework for efficient, scalable, and stable soft-realtime event processing."
url="https://cloudi.org/"
license="MIT"
@@ -61,14 +61,14 @@ makedepends="autoconf
options="!check"
subpackages="$pkgname-static $pkgname-openrc"
source="https://osdn.net/dl/cloudi/cloudi-$pkgver.tar.gz
- $pkgname.initd"
-
+ $pkgname.initd
+ 10-ocaml-32bit-fix.patch"
# configure additional dependencies based on the package architecture
# Enable OCaml on the appropriate architectures
case "$CTARGET_ARCH" in
- x86 | arm* | mips*)
+ mips*)
;;
*)
makedepends="$makedepends ocaml"
@@ -89,6 +89,8 @@ prepare() {
./autogen.sh
}
+export GO111MODULE=auto # go1.16 defaults to on
+
build() {
cd "$builddir"/src
export PATH="/usr/lib/jvm/java-1.8-openjdk/bin:$PATH"
@@ -119,4 +121,5 @@ package() {
}
sha512sums="c0525f390a68f1f38d8b0e0dfc97d367f1fa724e0265f4b19f4d688e808d5a192dbc8d1412408248cd4bb5acc9d9909ba893adc50efd0030e923252fabaa6208 cloudi-2.0.1.tar.gz
-053f860f656617012208a0e1909e43b2f8979d381a90d3fa5a745a9cf5021fe54556a641fef2badaa9955f2394d00e32183389cb9b501169dcbf8cbe4fbb0329 cloudi.initd"
+053f860f656617012208a0e1909e43b2f8979d381a90d3fa5a745a9cf5021fe54556a641fef2badaa9955f2394d00e32183389cb9b501169dcbf8cbe4fbb0329 cloudi.initd
+546ae9da76ec22462f25b0ea2daefd947d77e65d65e39a6e693c096cafd1806f5581381d1a93d4ca25057416bb08b89ce07d5ad555a598f961d8c8fa5c15d8c8 10-ocaml-32bit-fix.patch"