aboutsummaryrefslogtreecommitdiffstats
path: root/community/cmus
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-05-22 11:06:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-22 12:29:55 +0000
commitbedc9d65998058d1b5a1f3de7ecb2384418562f2 (patch)
tree718132a5f69c9ba621fc0c49feb6ee7e2ad31a0a /community/cmus
parent052fcc57045f4e5ead47f1136b6385ea85123c03 (diff)
community/cmus: upgrade to 2.8.0_rc0
Diffstat (limited to 'community/cmus')
-rw-r--r--community/cmus/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/community/cmus/APKBUILD b/community/cmus/APKBUILD
index a2fbab1f5ae..7f2cad93ce4 100644
--- a/community/cmus/APKBUILD
+++ b/community/cmus/APKBUILD
@@ -2,8 +2,9 @@
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Maintainer:
pkgname=cmus
-pkgver=2.7.1
-pkgrel=3
+pkgver=2.8.0_rc0
+pkgrel=0
+_ver=${pkgver/_rc/-rc}
pkgdesc="A very feature-rich ncurses-based music player"
url="http://cmus.sourceforge.net/"
arch="all"
@@ -11,24 +12,24 @@ license="GPL2+"
depends=""
depends_dev=""
makedepends="alsa-lib-dev faad2-dev flac-dev libmad-dev opusfile-dev
- libogg-dev libvorbis-dev ncurses-dev wavpack-dev ffmpeg2.8-dev
+ libogg-dev libvorbis-dev ncurses-dev wavpack-dev ffmpeg-dev
linux-headers"
install=""
subpackages="
$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
-source="$pkgname-$pkgver.tar.gz::https://github.com/cmus/cmus/archive/v${pkgver}.tar.gz"
+source="$pkgname-$_ver.tar.gz::https://github.com/cmus/cmus/archive/v${_ver}.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$_ver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure prefix=/usr || return 1
make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
for file in AUTHORS README.md; do
@@ -41,7 +42,7 @@ bashcomp() {
pkgdesc="Bash completions for $pkgname"
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- install -Dm644 "$_builddir"/contrib/$pkgname.bash-completion \
+ install -Dm644 "$builddir"/contrib/$pkgname.bash-completion \
"$subpkgdir"/usr/share/bash-completion/completions/$pkgname
}
@@ -50,10 +51,8 @@ zshcomp() {
pkgdesc="Zsh completions for $pkgname"
install_if="$pkgname=$pkgver-r$pkgrel zsh"
- install -Dm644 "$_builddir"/contrib/_$pkgname \
+ install -Dm644 "$builddir"/contrib/_$pkgname \
"$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
}
-md5sums="0588ab955db44a8e9deb03446d73b5df cmus-2.7.1.tar.gz"
-sha256sums="8179a7a843d257ddb585f4c65599844bc0e516fe85e97f6f87a7ceade4eb5165 cmus-2.7.1.tar.gz"
-sha512sums="b29ce10bbb61eb41c33c4912be320718fcf005a5797320145b124f048f6be5f5b0cebb67471ef7b062bd6f854849b6aae0e82e9adbf289a44237787932ea1576 cmus-2.7.1.tar.gz"
+sha512sums="0379f18497d6510fad35a2d905c932d12f2726a5694d3ab272ce139e9ea4520cb4dd1cf3fafe890f6ada8a64285f8c04ef7571647a66c2d44df17e2dca80f869 cmus-2.8.0-rc0.tar.gz"