aboutsummaryrefslogtreecommitdiffstats
path: root/community/cpio/APKBUILD
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-27 10:17:05 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-04 11:42:28 +0200
commit2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd (patch)
tree97c60fb3221dfe78cd7ccfda5db6125c81d5f676 /community/cpio/APKBUILD
parent00e8ff605f1c4f6386596f35f2a5287ff9b8bc55 (diff)
testing/[various]: move packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. asciinema at calcurse cmus compton cpio dvd+rw-tools fortune fvwm geary h2o heirloom-mailx leafpad nedit nmh rover tor torsocks urlview vdesk w3m wbar xcalc xclock xeyes xkill
Diffstat (limited to 'community/cpio/APKBUILD')
-rw-r--r--community/cpio/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/cpio/APKBUILD b/community/cpio/APKBUILD
new file mode 100644
index 00000000000..de3af23d988
--- /dev/null
+++ b/community/cpio/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=cpio
+pkgver=2.12
+pkgrel=0
+pkgdesc="A tool to copy files into or out of a cpio or tar archive"
+url="http://www.gnu.org/software/cpio"
+arch="all"
+license="GPL"
+depends="tar"
+depends_dev=""
+makedepends="$depends_dev"
+#install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.bz2::http://ftp.snt.utwente.nl/pub/software/gnu/cpio/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/charset.alias
+ rm -f "$pkgdir"/usr/libexec/rmt # part of the tar pkg
+}
+
+md5sums="93eea9f07c0058c097891c73e4955456 cpio-2.12.tar.bz2"
+sha256sums="70998c5816ace8407c8b101c9ba1ffd3ebbecba1f5031046893307580ec1296e cpio-2.12.tar.bz2"
+sha512sums="0cd4da5f2fbca179ab4e666a5f878414c086a5f98bce4c76273f21d9b2a6fe422d901b5d453826c5f81bbe363aa015047a1e99779ad1a451c8feca6205c63120 cpio-2.12.tar.bz2"