aboutsummaryrefslogtreecommitdiffstats
path: root/community/darktable/APKBUILD
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2021-07-28 19:58:19 +0000
committerAndy Postnikov <apostnikov@gmail.com>2021-07-28 20:29:09 +0000
commit06e7165097722a87ff5c07670546faacd3a3e3a6 (patch)
treede396a7b3102f51ca9c5c291e5c90fa0d285c320 /community/darktable/APKBUILD
parent69d5f2c359b36db5347c6b25108440280ae5e438 (diff)
community/darktable: build with -O2 to fix build
Building with -Os segfaults 3.6.0, and as this is a computation heavy application, building it with -O2 makes sense, while not increasing the package size all that much: > Size difference for darktable: 15 MiB -> 16 MiB
Diffstat (limited to 'community/darktable/APKBUILD')
-rw-r--r--community/darktable/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/darktable/APKBUILD b/community/darktable/APKBUILD
index 5c19f62775c..d4e5ff8127e 100644
--- a/community/darktable/APKBUILD
+++ b/community/darktable/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=darktable
pkgver=3.6.0
-pkgrel=0
+pkgrel=1
pkgdesc="an open source photography workflow application and raw developer"
url="https://www.darktable.org/"
arch="x86_64 aarch64"
@@ -50,6 +50,7 @@ prepare() {
build() {
cd "$builddir/build"
+ export CXXFLAGS="$CXXFLAGS -O2"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \