aboutsummaryrefslogtreecommitdiffstats
path: root/community/detenc
diff options
context:
space:
mode:
authorEd Robinson <ed.robinson@reevoo.com>2017-07-03 09:15:18 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-10 19:02:42 +0000
commit6e33426e8e62d434382adbd857d04bf2002bcf48 (patch)
treed8f3ff39ad12caed29fc842ac24910a1046f1283 /community/detenc
parent8b513e216ef1034a2a4d6b988adc873c930215ab (diff)
testing/detenc: improve APKBUILD and move to community
Diffstat (limited to 'community/detenc')
-rw-r--r--community/detenc/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/detenc/APKBUILD b/community/detenc/APKBUILD
new file mode 100644
index 00000000000..f43ee5fcf86
--- /dev/null
+++ b/community/detenc/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Ed Robinson <ed+alpine@reevoo.com>
+# Maintainer: Ed Robinson <ed+alpine@reevoo.com>
+pkgname=detenc
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A lightweight, low-memory character encoding detector"
+url="https://github.com/reevoo/detenc"
+arch="all"
+license="MIT"
+depends=""
+makedepends="ruby-rake ruby-minitest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/reevoo/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir"/bin
+ make PREFIX="$pkgdir" -C "$builddir" install
+}
+
+sha512sums="b4c0dc71a699b2e30a345d641781bd58146be84a727e89dc9ef39da7ddb752659371ba8fc37b345c514b43f92723ef80c9bbe73c72a562a2729a1626ec3f53db detenc-2.0.0.tar.gz"