aboutsummaryrefslogtreecommitdiffstats
path: root/community/docker-registry/APKBUILD
diff options
context:
space:
mode:
authorChristian Kampka <christian@kampka.net>2016-04-16 15:48:29 +0200
committerChristian Kampka <christian@kampka.net>2016-04-16 15:48:29 +0200
commit7a3870ab68812ca1be06f8c3cb8f9b146221bdef (patch)
tree200bf961b95596fad5cb68426480bb2eec7fee03 /community/docker-registry/APKBUILD
parent3170d56546dd3d8bf10937f76bf14577d5a9368f (diff)
community/docker-registry: fix build path
Diffstat (limited to 'community/docker-registry/APKBUILD')
-rw-r--r--community/docker-registry/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/docker-registry/APKBUILD b/community/docker-registry/APKBUILD
index 0a2430e708b..325482f11d7 100644
--- a/community/docker-registry/APKBUILD
+++ b/community/docker-registry/APKBUILD
@@ -31,7 +31,8 @@ build() {
export GOPATH="${DISTRIBUTION_DIR}/Godeps/_workspace"
cd "${DISTRIBUTION_DIR}"
# GOPATH fix
- ln -s "${DISTRIBUTION_DIR}" "${DISTRIBUTION_DIR}/Godeps/_workspace/src/github.com/docker/distribution"
+ mkdir -p "${DISTRIBUTION_DIR}/Godeps/_workspace/src/github.com/docker/" || return 1
+ ln -s "${DISTRIBUTION_DIR}" "${DISTRIBUTION_DIR}/Godeps/_workspace/src/github.com/docker/distribution" || return 1
make clean binaries || return 1
}