aboutsummaryrefslogtreecommitdiffstats
path: root/community/duo_unix
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-05 14:25:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:28 +0000
commitd389d9a12e4ea9dc34c2e8547f76a8e52c07203b (patch)
treedebf0e7c8f1292bca366b4ac59b3f7516ec44533 /community/duo_unix
parent6d95f20d6b0e9e11d47d9eba675ce36d9fdf70dc (diff)
community/duo_unix: fix rebuild against libressl-2.7
Diffstat (limited to 'community/duo_unix')
-rw-r--r--community/duo_unix/APKBUILD8
-rw-r--r--community/duo_unix/libressl-2.7.patch13
2 files changed, 18 insertions, 3 deletions
diff --git a/community/duo_unix/APKBUILD b/community/duo_unix/APKBUILD
index d0ba7c678ae..6dc050657a0 100644
--- a/community/duo_unix/APKBUILD
+++ b/community/duo_unix/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paul Morgan <jumanjiman@gmail.com>
pkgname=duo_unix
pkgver=1.10.2
-pkgrel=0
+pkgrel=1
pkgdesc="duosecurity.com two-factor authentication"
url="https://duo.com/support/documentation/duounix"
arch="all"
@@ -12,7 +12,8 @@ depends_dev="libressl-dev zlib-dev"
makedepends="$depends_dev automake autoconf libtool"
options="suid"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/duosecurity/duo_unix/archive/$pkgname-$pkgver.tar.gz"
+source="https://github.com/duosecurity/duo_unix/archive/$pkgname-$pkgver.tar.gz
+ libressl-2.7.patch"
builddir="$srcdir"/$pkgname-$pkgname-$pkgver
prepare() {
@@ -36,4 +37,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="9ef9815e02528e5093e97c8ba2aae86676be5a86a838632755e6dffef53d49df101c3a5f67f4c672a2ca0663f0a35440ce377f51203846b270263f4745388165 duo_unix-1.10.2.tar.gz"
+sha512sums="9ef9815e02528e5093e97c8ba2aae86676be5a86a838632755e6dffef53d49df101c3a5f67f4c672a2ca0663f0a35440ce377f51203846b270263f4745388165 duo_unix-1.10.2.tar.gz
+aceb647dfbeb8a0f159c827b7fbec7703b9d9895adc26d06ad6be91828e1c20569c2a087bbb0d04390a1ec1f9c0217ca3bae3f6fd9f971d754ff0306e5ed88a2 libressl-2.7.patch"
diff --git a/community/duo_unix/libressl-2.7.patch b/community/duo_unix/libressl-2.7.patch
new file mode 100644
index 00000000000..8a4269dd690
--- /dev/null
+++ b/community/duo_unix/libressl-2.7.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/https.c b/lib/https.c
+index 33c296a..b526add 100644
+--- a/lib/https.c
++++ b/lib/https.c
+@@ -353,7 +353,7 @@ _establish_connection(struct https_request * const req,
+ * building for OpenSSL versions older than 1.1.0
+ * or any version of LibreSSL.
+ */
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ static HMAC_CTX *
+ HMAC_CTX_new(void)
+ {