aboutsummaryrefslogtreecommitdiffstats
path: root/community/duo_unix
diff options
context:
space:
mode:
authorPaul Morgan <jumanjiman@gmail.com>2018-08-27 17:05:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-03 10:25:38 +0000
commitd97aa89204c66dbd765a10ddf7a097e534cf818e (patch)
treee981b94903ff51baa155ce5511ba63d7b68788e1 /community/duo_unix
parent3b19bc6ba8109fc1fb681c265c51415bba6b4ee6 (diff)
community/duo_unix: upgrade to 1.10.4
Upstream now includes the patch for libressl 2.7.
Diffstat (limited to 'community/duo_unix')
-rw-r--r--community/duo_unix/APKBUILD8
-rw-r--r--community/duo_unix/libressl-2.7.patch13
2 files changed, 3 insertions, 18 deletions
diff --git a/community/duo_unix/APKBUILD b/community/duo_unix/APKBUILD
index 78cfbd54841..9925f57c6e1 100644
--- a/community/duo_unix/APKBUILD
+++ b/community/duo_unix/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
# Maintainer: Paul Morgan <jumanjiman@gmail.com>
pkgname=duo_unix
-pkgver=1.10.3
+pkgver=1.10.4
pkgrel=0
pkgdesc="duosecurity.com two-factor authentication"
url="https://duo.com/support/documentation/duounix"
@@ -12,8 +12,7 @@ depends_dev="libressl-dev zlib-dev"
makedepends="$depends_dev automake autoconf libtool"
options="suid"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/duosecurity/duo_unix/archive/$pkgname-$pkgver.tar.gz
- libressl-2.7.patch"
+source="https://github.com/duosecurity/duo_unix/archive/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgname-$pkgver
prepare() {
@@ -37,5 +36,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="fec222803d483e55823c1d5586852b718774f86565211b946971c8136af09e4902d747f7462e48c61bdb6615fd1327f18c11984bf49bbaefcbe7055cb221f7b2 duo_unix-1.10.3.tar.gz
-9311bef67fb1f0260d47f6079ffec037bcbc273e07f5f839ee5cdbee66b933376018027590a015508d7be243507a630944456905ccbe49baf2a993d9f0f5a845 libressl-2.7.patch"
+sha512sums="3a532492423d7242a172744539bac5bedea181ca2af3cd85546d03f7c8a19b01e98f8c696478324b2e24a237e80255746b4eee7d6aa94d7f11684f45ba88c4f9 duo_unix-1.10.4.tar.gz"
diff --git a/community/duo_unix/libressl-2.7.patch b/community/duo_unix/libressl-2.7.patch
deleted file mode 100644
index cd6b583a3b5..00000000000
--- a/community/duo_unix/libressl-2.7.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/lib/https.c b/lib/https.c
-index 33c296a..b526add 100644
---- a/lib/https.c
-+++ b/lib/https.c
-@@ -353,7 +353,7 @@ _establish_connection(struct https_request * const req,
- * building for OpenSSL versions older than 1.1.0
- * or any version of LibreSSL.
- */
--#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || LIBRESSL_VERSION_NUMBER < 0x2070000fL
- static HMAC_CTX *
- HMAC_CTX_new(void)
- {