aboutsummaryrefslogtreecommitdiffstats
path: root/community/dvgrab/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 15:36:20 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 19:23:24 +0000
commit86347fb76ea35d4465b5198c100d095e42142eab (patch)
treee47d03841b983704cd06dd8ee25ca010d0e89b17 /community/dvgrab/APKBUILD
parent6f56b82cbb3d74747286de59ba96e6a2e36bbebf (diff)
community/dvgrab: move from main
Diffstat (limited to 'community/dvgrab/APKBUILD')
-rw-r--r--community/dvgrab/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/dvgrab/APKBUILD b/community/dvgrab/APKBUILD
new file mode 100644
index 00000000000..f8af684dd8e
--- /dev/null
+++ b/community/dvgrab/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dvgrab
+pkgver=3.5
+pkgrel=3
+pkgdesc="Utility to capture video from a DV camera"
+url="http://www.kinodv.org/"
+arch="all"
+license="GPL-2.0-or-later"
+depends=
+makedepends="libraw1394-dev libavc1394-dev libdv-dev libiec61883-dev
+ libjpeg-turbo-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://prdownloads.sourceforge.net/kino/dvgrab-$pkgver.tar.gz
+ musl-fixes.patch
+ fix-narrowing.patch
+ "
+
+builddir="$srcdir"/dvgrab-$pkgver
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="7d9cae1661d27dbef1d0dcdf18966a0ab386d936803ff7d071a18e0303fca45631c9b27187a413adfa4391c395e5909e3b8dc5c543d529e7805550f1a3ee6735 dvgrab-3.5.tar.gz
+c69220fa133812063fc6e237a1c15215b7163845d8f9b0e0aba589a86b875f194d2a6899f44449c3e209415ea94d14a13eeff23014ddda0e8a496a6973a0e21b musl-fixes.patch
+9c54e630efcbf2992e785a837b24abc62d064e5538156f4d8a4b16edea1d55a7a2a70163564b3139f29c33c8887166fea0a253da0a4e6bb540142bf5054c551d fix-narrowing.patch"