aboutsummaryrefslogtreecommitdiffstats
path: root/community/entr
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-03-01 19:46:08 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-03-02 01:19:10 +0000
commit310ad01d4fd3fdbd43ff59324828cac5248577d4 (patch)
tree119d6f820a25616826fc06af72816da3b66a69e5 /community/entr
parent2011c399cb5f795da0ee656c418b014b8fac9655 (diff)
community/entr: update to 3.7
Diffstat (limited to 'community/entr')
-rw-r--r--community/entr/APKBUILD28
-rw-r--r--community/entr/fix-tests.patch11
2 files changed, 32 insertions, 7 deletions
diff --git a/community/entr/APKBUILD b/community/entr/APKBUILD
index e0c22869b0b..4482c87b950 100644
--- a/community/entr/APKBUILD
+++ b/community/entr/APKBUILD
@@ -1,16 +1,27 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=entr
-pkgver=3.6
-_hgrev=c15b0be493fc
+pkgver=3.7
pkgrel=0
pkgdesc="Event Notify Test Runner: Run arbitrary commands when files change"
url="http://entrproject.org"
arch="all"
license="ISC BSD"
subpackages="$pkgname-doc"
-source="http://entrproject.org/code/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/eradman-$pkgname-$_hgrev"
+makedepends="vim mercurial file util-linux"
+checkdepends="bash"
+source="http://entrproject.org/code/$pkgname-$pkgver.tar.gz
+ fix-tests.patch
+ "
+builddir="$srcdir/eradman-$pkgname"
+
+prepare() {
+ # Top-level directory inside the tar archive contains SHA of a commit...
+ cd "$srcdir"
+ mv eradman-$pkgname-* "$builddir"
+
+ default_prepare
+}
build() {
cd "$builddir"
@@ -23,6 +34,9 @@ package() {
PREFIX="$pkgdir/usr" make install || return 1
}
-md5sums="072eed7153296a8fae6ebdedefed9fd4 entr-3.6.tar.gz"
-sha256sums="a42746d81c548d7e557d500f93422b8ec9731d719309eb2601b8be69ae0dc8eb entr-3.6.tar.gz"
-sha512sums="a4f607d69e2222ffaeb50c57532fafa88db550d4ab4c633e57e895a8291bb38f6bdd09e92dba2e6fc70e035b2db050ab4c75fb39cd24d00fbde07ef0c03fff8f entr-3.6.tar.gz"
+check() {
+ make regress || return 1
+}
+
+sha512sums="a1687ec2da99f65fba3f668e41345ba76cb8c87cc2343d98c0dcc0ac0dedeb40cd8b5fd9aa3eba1dee8add94585de939864633bf0020cea1043699019dfa15fe entr-3.7.tar.gz
+76ff681ba95fd373f3fe466e1e63fdabf97e16bfe054710b86f7f76c69c45f3fc84ecbf940fa8603740093817e39b35d0af2c3fef1a66a2eed1c3ef442dd207f fix-tests.patch"
diff --git a/community/entr/fix-tests.patch b/community/entr/fix-tests.patch
new file mode 100644
index 00000000000..e7d7e5f9e05
--- /dev/null
+++ b/community/entr/fix-tests.patch
@@ -0,0 +1,11 @@
+--- eradman-entr-c5b62bde107d/system_test.sh
++++ eradman-entr-c5b62bde107d/system_test.sh.new
+@@ -304,7 +304,7 @@
+ kill -INT $bgpid
+ wait $bgpid || assert "$?" "130"
+ assert "$(cat $tmp/exec.err)" ""
+- assert "$(cat $tmp/exec.out)" "$(printf ${tmp}'/file2: ASCII text')"
++ assert "$(head -n1 $tmp/exec.out)" "$(printf ${tmp}'/file2: ASCII text')"
+
+ # extra slow tests that rely on timeouts
+