aboutsummaryrefslogtreecommitdiffstats
path: root/community/entr
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-13 21:29:26 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-13 21:29:26 +0200
commit8f8bb7e101e61e9b06551fee216141f3b033b96c (patch)
tree768c5769b75d7fb177e1a072b3321df03fa2cca3 /community/entr
parent8a66e1b0520aa3fc9810cfbbad877a0cc7e53af1 (diff)
community/entr: modernize APKBUILD
Diffstat (limited to 'community/entr')
-rw-r--r--community/entr/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/community/entr/APKBUILD b/community/entr/APKBUILD
index 880ebcfab61..66b41485889 100644
--- a/community/entr/APKBUILD
+++ b/community/entr/APKBUILD
@@ -15,28 +15,27 @@ source="http://entrproject.org/code/$pkgname-$pkgver.tar.gz
"
builddir="$srcdir/eradman-$pkgname"
-prepare() {
- # Top-level directory inside the tar archive contains SHA of a commit...
- cd "$srcdir"
- mv eradman-$pkgname-* "$builddir"
+unpack() {
+ default_unpack
- default_prepare
+ # Top-level directory inside the tar archive contains SHA of a commit...
+ mv "$srcdir"/eradman-$pkgname-* "$builddir"
}
build() {
cd "$builddir"
- ./configure || return 1
- CFLAGS="-static" make test || return 1
+ ./configure
+ CFLAGS="-static" make test
}
package() {
cd "$builddir"
- PREFIX="$pkgdir/usr" make install || return 1
+ PREFIX="$pkgdir/usr" make install
}
check() {
cd "$builddir"
- make regress || return 1
+ make regress
}
sha512sums="a1687ec2da99f65fba3f668e41345ba76cb8c87cc2343d98c0dcc0ac0dedeb40cd8b5fd9aa3eba1dee8add94585de939864633bf0020cea1043699019dfa15fe entr-3.7.tar.gz