aboutsummaryrefslogtreecommitdiffstats
path: root/community/erlang/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-25 14:18:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-25 14:19:49 +0000
commite1e33746131a7b1d2256df03ee8ceaa2058f134f (patch)
treef0f38479cf85bd8278e1ed375d3cfba97280fa33 /community/erlang/APKBUILD
parent17d98092466a62deff02bc83571d3c0d975a70fe (diff)
community/erlang: fix build dep and use openjdk8
Diffstat (limited to 'community/erlang/APKBUILD')
-rw-r--r--community/erlang/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/erlang/APKBUILD b/community/erlang/APKBUILD
index 6963e8dc74e..aa788b9d882 100644
--- a/community/erlang/APKBUILD
+++ b/community/erlang/APKBUILD
@@ -11,7 +11,8 @@ url="http://www.erlang.org/"
license="ASL 2.0"
arch="all"
depends="$pkgname-kernel $pkgname-stdlib $pkgname-compiler"
-makedepends="perl-dev zlib-dev ncurses-dev libressl-dev openjdk7 unixodbc-dev"
+makedepends="perl-dev zlib-dev ncurses-dev libressl-dev openjdk8 unixodbc-dev
+ autoconf"
subpackages="$pkgname-dev
$pkgname-asn1:asn
$pkgname-common-test:common_test
@@ -74,7 +75,7 @@ prepare() {
build() {
cd "$builddir"
export CPPFLAGS="-D_BSD_SOURCE $CPPFLAGS"
- export PATH="/usr/lib/jvm/java-1.7-openjdk/bin:$PATH"
+ export PATH="/usr/lib/jvm/java-1.8-openjdk/bin:$PATH"
./otp_build autoconf
./configure --prefix=/usr \
--sysconfdir=/etc \