aboutsummaryrefslogtreecommitdiffstats
path: root/community/etckeeper
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2017-12-20 11:57:20 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-27 14:42:12 +0100
commit917041212d6841b0924e93e5b5abe6f8ac811b9d (patch)
treeb3a208c79731d16d2d20f4669f4e803267210e87 /community/etckeeper
parent34ceaf65b946bfb564f0e83b9dcae045c3d5b1b1 (diff)
community/etckeeper: do not warn for hard links
Diffstat (limited to 'community/etckeeper')
-rw-r--r--community/etckeeper/APKBUILD4
-rw-r--r--community/etckeeper/apk-commit_hook5
2 files changed, 7 insertions, 2 deletions
diff --git a/community/etckeeper/APKBUILD b/community/etckeeper/APKBUILD
index 39d2efb3685..9e482594180 100644
--- a/community/etckeeper/APKBUILD
+++ b/community/etckeeper/APKBUILD
@@ -3,7 +3,7 @@
pkgname=etckeeper
pkgver=1.18.7
-pkgrel=1
+pkgrel=2
pkgdesc="Store /etc in git."
url="http://etckeeper.branchable.com"
arch="noarch"
@@ -48,5 +48,5 @@ package() {
}
sha512sums="44b8f66b95663da1370943128bb5673e57bd7b9df7e727c93baea5dfc79852ebba9d0834827fed19722668849d3ed18b045db5cb42135e198576a2b839523d1a etckeeper-1.18.7.tar.gz
-2b1a29d31b6e7cf4ddb05de9b5e088b5747c2abfb2d63f9bddd25f4b7dc8503d457df7fd644afe5bd6fea6a5285a111a47c0489d24378b483c1e026cc11c6bf7 apk-commit_hook
+d0ff88615359e8b03da5f9162a7bae3f32c06891a8899096025283d77e950dd72280c6c19b8eb8a4cde08742c6ca715cd32c37c16e8bbf2d030e9fd16a1fc940 apk-commit_hook
d4aa516f7b35c2eddd5c534391fd6363429633aea3b4b2e8e46b1fe192986c79f91bf9e3e808992ce524ffc3ac96cc3952d1a1e7c3b355b7f97ffa9badc8b8d0 0001-Work-around-git-commit-s-lack-of-robustness-by-provi.patch"
diff --git a/community/etckeeper/apk-commit_hook b/community/etckeeper/apk-commit_hook
index 6f0a4c043ce..a662c81a817 100644
--- a/community/etckeeper/apk-commit_hook
+++ b/community/etckeeper/apk-commit_hook
@@ -2,6 +2,11 @@
[ -x /usr/bin/etckeeper ] || exit
+[ -x /usr/bin/git ] || exit
+[ -x /usr/bin/find ] || exit
+
+AVOID_SPECIAL_FILE_WARNING=1
+export AVOID_SPECIAL_FILE_WARNING
case "$1" in
pre-commit)