aboutsummaryrefslogtreecommitdiffstats
path: root/community/exempi/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-06 14:23:55 +0200
committerprspkt <prspkt@protonmail.com>2019-05-07 11:43:18 +0300
commit0e19375e070acd4d57a884385942b6c375de26c2 (patch)
tree774734a3dcf7701f353141617bd47d29e41b41fa /community/exempi/APKBUILD
parentfb1d85ee7b2a1602496fdd3ae56fd654a64d6c87 (diff)
community/exempi: move from community, required for eog
* Adopt maintainership * Fix license * Modernize APKBUILD
Diffstat (limited to 'community/exempi/APKBUILD')
-rw-r--r--community/exempi/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/exempi/APKBUILD b/community/exempi/APKBUILD
new file mode 100644
index 00000000000..b4567855a7f
--- /dev/null
+++ b/community/exempi/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=exempi
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="A library to parse XMP metadata"
+url="https://libopenraw.freedesktop.org/wiki/Exempi/"
+arch="all"
+license="BSD-3-Clause"
+makedepends="expat-dev zlib-dev boost-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://libopenraw.freedesktop.org/download/exempi-$pkgver.tar.bz2"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="1d042ffe3c3daadf937c4938e7892d52c4835275065e159f7991ddc9f533424fb6cd7d607600c3381440020db9dfa06af5ae15168d7a8012358fa5c8ac453bba exempi-2.5.0.tar.bz2"