aboutsummaryrefslogtreecommitdiffstats
path: root/community/extra-cmake-modules/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-22 17:19:03 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-22 20:24:45 -0300
commit65b30edae889224be20e58725bdde656dd460884 (patch)
tree6a2669ae75988727e35ac7c239aa3d32c3bf6dbc /community/extra-cmake-modules/APKBUILD
parent0eda0ef48ed308cf452fbdb3ce573054ab56dd1a (diff)
community/extra-cmake-modules: use py3-sphinx to build docs
Diffstat (limited to 'community/extra-cmake-modules/APKBUILD')
-rw-r--r--community/extra-cmake-modules/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/extra-cmake-modules/APKBUILD b/community/extra-cmake-modules/APKBUILD
index 09045bbd567..d0ce95f0b44 100644
--- a/community/extra-cmake-modules/APKBUILD
+++ b/community/extra-cmake-modules/APKBUILD
@@ -9,7 +9,7 @@ url="https://projects.kde.org/projects/kdesupport/extra-cmake-modules"
arch="noarch"
license="BSD-3-Clause"
depends="cmake"
-makedepends="py-sphinx"
+makedepends="py3-sphinx"
checkdepends="qt5-qtbase-dev qt5-qtquickcontrols2-dev"
subpackages="$pkgname-doc"
source="http://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
@@ -17,7 +17,8 @@ source="http://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.
build() {
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_TESTING=ON
+ -DBUILD_TESTING=ON \
+ -DSphinx_BUILD_EXECUTABLE=/usr/bin/sphinx-build-3
make
}