aboutsummaryrefslogtreecommitdiffstats
path: root/community/fbpanel
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-08-18 12:58:33 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-18 21:11:39 +0000
commitfad19051951129081c94d9ca641af6bbb1389e20 (patch)
tree4f6fac56923653086b9db2df0052a834b70b6966 /community/fbpanel
parent5df6fbc76284929c44d2db7db6d12f675a91958c (diff)
testing/[various]: move to community
Moves the following packages to community after successful build and testing. bogofilter corebird fbpanel hermes libdbi-drivers luufs netsurf opencpn py-sensehat rng-tools volumeicon
Diffstat (limited to 'community/fbpanel')
-rw-r--r--community/fbpanel/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/fbpanel/APKBUILD b/community/fbpanel/APKBUILD
new file mode 100644
index 00000000000..0cae5685078
--- /dev/null
+++ b/community/fbpanel/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=fbpanel
+pkgver=7.0
+pkgrel=0
+pkgdesc="A lightweight, NETWM compliant desktop panel."
+url="http://aanatoly.github.io/fbpanel/"
+arch="all"
+license="Other"
+depends=""
+depends_dev=""
+makedepends="coreutils linux-headers gtk+2.0-dev bash"
+install=""
+subpackages="$pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/aanatoly/$pkgname/archive/${pkgver}.tar.gz"
+
+builddir=${srcdir}/${pkgname}-${pkgver}
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/fbpanal \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR=$pkgdir install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+md5sums="8a15ac4e0f23a72b9d6be5151df712e5 fbpanel-7.0.tar.gz"
+sha256sums="711570954f8f99235d6afb7ec3226dede20b832eb712a5bd00e4f793b75ac5bb fbpanel-7.0.tar.gz"
+sha512sums="9706a96569c41241de4dbd250c9d6a473b53a5e26e880f4c782041b2b91c7570046e1bee3070059fd2d333fb7159490732ef397b86701c72d4c65c0784948874 fbpanel-7.0.tar.gz"