aboutsummaryrefslogtreecommitdiffstats
path: root/community/feh/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-11 21:01:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-11 21:01:16 -0300
commit93fd7ec120b74ab4299facadcae04d995ce7cbed (patch)
tree9ba84554ecb54f2c902643d32c01f4102a5e1151 /community/feh/APKBUILD
parentbf2d17b50e6fd2d30f574da04d5c5c5667269052 (diff)
community/feh: add preliminary support for tests
Diffstat (limited to 'community/feh/APKBUILD')
-rw-r--r--community/feh/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/community/feh/APKBUILD b/community/feh/APKBUILD
index 58dd6fa3c48..cc0cf0057a4 100644
--- a/community/feh/APKBUILD
+++ b/community/feh/APKBUILD
@@ -4,18 +4,24 @@ pkgname=feh
pkgver=3.4
pkgrel=0
pkgdesc="Fast, lightweight image viewer which uses imlib2"
+options="!check" # Requires unpackaged 'perl-test-command'
url="https://feh.finalrewind.org"
arch="all"
license="MIT-feh"
subpackages="$pkgname-doc"
makedepends="curl-dev imlib2-dev libjpeg-turbo-dev libpng-dev
libxinerama-dev libxt-dev"
+checkdepends="perl-utils"
source="https://feh.finalrewind.org/feh-$pkgver.tar.bz2"
build() {
make PREFIX=/usr
}
+check() {
+ make test
+}
+
package() {
make PREFIX=/usr DESTDIR="$pkgdir" \
bin_dir="$pkgdir"/usr/bin \