aboutsummaryrefslogtreecommitdiffstats
path: root/community/ffmpeg/APKBUILD
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2022-02-11 09:26:38 +0100
committeralice <alice@ayaya.dev>2022-02-21 08:25:32 +0000
commitb9bcd7109cd2dec4e7bbfa2a233c2f535ab94594 (patch)
treebf696abbb0fdbcc374bdc6e707d251453c1f9b06 /community/ffmpeg/APKBUILD
parent5666f995ce86fdd58f14e236aa66767ad64f9050 (diff)
community/ffmpeg: enable libdrm and libpulse
Diffstat (limited to 'community/ffmpeg/APKBUILD')
-rw-r--r--community/ffmpeg/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/ffmpeg/APKBUILD b/community/ffmpeg/APKBUILD
index d2554579381..a80b9947d3d 100644
--- a/community/ffmpeg/APKBUILD
+++ b/community/ffmpeg/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ffmpeg
pkgver=4.4.1
-pkgrel=3
+pkgrel=4
pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix"
url="https://ffmpeg.org/"
arch="all"
@@ -20,6 +20,7 @@ makedepends="
imlib2-dev
lame-dev
libass-dev
+ libdrm-dev
libsrt-dev
libssh-dev
libtheora-dev
@@ -31,6 +32,7 @@ makedepends="
libxfixes-dev
opus-dev
perl-dev
+ pulseaudio-dev
sdl2-dev
soxr-dev
v4l-utils-dev
@@ -158,6 +160,7 @@ build() {
--enable-gpl \
--enable-libass \
--enable-libmp3lame \
+ --enable-libpulse \
--enable-libvorbis \
--enable-libvpx \
--enable-libxvid \
@@ -185,6 +188,7 @@ build() {
--enable-vaapi \
--enable-vdpau \
--enable-vulkan \
+ --enable-libdrm \
$_asm $_dbg
make
${CC:-gcc} -o tools/qt-faststart $CFLAGS tools/qt-faststart.c