aboutsummaryrefslogtreecommitdiffstats
path: root/community/firefox-esr
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-20 03:16:55 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-20 03:17:15 +0200
commit303b731836b4b206657ef5f944d8ca4c178ca4cf (patch)
treecbd97e8680bc17047e78aba726280547ced9e15e /community/firefox-esr
parent3fc5d9c2eb7d3d38c00d92d6fe40630711a0a6d7 (diff)
community/firefox-esr: build fix gcc6
Diffstat (limited to 'community/firefox-esr')
-rw-r--r--community/firefox-esr/APKBUILD9
-rw-r--r--community/firefox-esr/gcc6-fix-compilation.patch49
-rw-r--r--community/firefox-esr/mozilla-flexible-array-member-in-union.patch22
3 files changed, 79 insertions, 1 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index c2cbc248fee..c04d5d83146 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -70,6 +70,8 @@ source="http://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-
allow-utf8-fallback.patch
libavutil.patch
mallinfo.patch
+ gcc6-fix-compilation.patch
+ mozilla-flexible-array-member-in-union.patch
firefox.desktop
firefox-safe.desktop"
@@ -106,7 +108,6 @@ build() {
# set rpath so linker finds the libs
export LDFLAGS="$LDFLAGS -Wl,-rpath,${_mozappdir}"
-
make -f client.mk build \
STRIP="/bin/true" \
|| return 1
@@ -186,6 +187,8 @@ f29e0036edc7b3a4158a82fa97bde500 fix-fortify-inline.patch
1feef5ea2fd5acc2a71a29350754d006 allow-utf8-fallback.patch
b8b2a3cdb38f402e4eb4885908233811 libavutil.patch
0db0cce8350d59a91ae2c4f0400f7146 mallinfo.patch
+c35d743dd706093ff5aa7dbb7e6168bb gcc6-fix-compilation.patch
+538d28df9b39cd80e30314411765a98a mozilla-flexible-array-member-in-union.patch
ba96924ece1d77453e462429037a2ce5 firefox.desktop
6f38a5899034b7786cb1f75ad42032b8 firefox-safe.desktop"
sha256sums="1a729774034231c919dc5a556e17d3342792d5347c755d8d0a4f67a07374804b firefox-45.2.0esr.source.tar.xz
@@ -205,6 +208,8 @@ cd19195cb4c316ad9f7d377cd8581218c888863b1bc4d112c97f48a4425fb946 fix-fortify-sy
a1ba79ec0c50c19edcfb24bb2686a718a77b02035e412989b9208b9b818abe14 allow-utf8-fallback.patch
83113f1fbc0389602b3623e8a5428d41837c4ec9557615c37ca05619526a7404 libavutil.patch
2f564fa5f347f3c7f20d589ef273f000ca9c9aeca2c6ad0fb5b15bfc715d8b81 mallinfo.patch
+5ae2edf65b65a29c8d266343230c0ba9268f864697fc1f984d79e980a365a8fc gcc6-fix-compilation.patch
+a3cb90955b44fca673e574e11b71114dc616448349b61b9e9e78b3020c20d97a mozilla-flexible-array-member-in-union.patch
b571c4a49884a3c98806246c9cc3e60c73d5a8f4aeb7f96217db0be1d6210eda firefox.desktop
4b6de45753856a890f4482055666e77f9b01bdfb7e0df08bafaa3a4d9937eed3 firefox-safe.desktop"
sha512sums="fd67353cff9400080a311af92562b1ed26d20ca2229e32e8c8289b364ebe27fd501eed78c72b614e0501c3841ae9b17f2102158fbeef5083bee8c12d952660e6 firefox-45.2.0esr.source.tar.xz
@@ -224,5 +229,7 @@ c69cdb2d6c66180d6a67c386b862a5ed953aab4db434b054c9e1e6702bcc56ba219a4cb22747d9c8
ebbc2b1336197c289e9b7c073d196fb5734e1dad0109fe70538f8089b1873e4b55305cd39cefcf95cd4eb36715be6dff298856c496616e935ff5579452e62b09 allow-utf8-fallback.patch
2213dbd7eb36f954add09977c0bb979aea79376164bc98d7e8957ecf584776bc11cc88b6d8235f9e04ac69d5975a47c2f52fd9aff9076326f15997657af8c9f3 libavutil.patch
bdcd1b402d2ec94957ba5d08cbad7b1a7f59c251c311be9095208491a05abb05a956c79f27908e1f26b54a3679387b2f33a51e945b650671ad85c0a2d59a5a29 mallinfo.patch
+09288e3c9b94e7bfb4f764c506d98315ab3a44926cca59183dd22a84184c1de44f5dbe973367ec0ee0200d438c028e1dbe9fce4d9ce92f0e1367be50a9a72671 gcc6-fix-compilation.patch
+2784fd73d7208f44d1db150c0a44d3f56029d20ede2f59aed70ea8feb09ac87031308ee817c998bf00dd17c0e794c9f2a90a2bfe520510417b0cd7202ea41815 mozilla-flexible-array-member-in-union.patch
f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop"
diff --git a/community/firefox-esr/gcc6-fix-compilation.patch b/community/firefox-esr/gcc6-fix-compilation.patch
new file mode 100644
index 00000000000..1c1dba27e28
--- /dev/null
+++ b/community/firefox-esr/gcc6-fix-compilation.patch
@@ -0,0 +1,49 @@
+diff -r 34544e6dfc19 -r 55212130f19d config/gcc-stl-wrapper.template.h
+--- a/config/gcc-stl-wrapper.template.h Fri Mar 11 11:45:09 2016 +0800
++++ b/config/gcc-stl-wrapper.template.h Thu Mar 10 16:54:05 2016 +0900
+@@ -12,33 +12,40 @@
+ // compiling ObjC.
+ #if defined(__EXCEPTIONS) && __EXCEPTIONS && !(__OBJC__ && __GNUC__ && XP_IOS)
+ # error "STL code can only be used with -fno-exceptions"
+ #endif
+
+ // Silence "warning: #include_next is a GCC extension"
+ #pragma GCC system_header
+
++// Don't include mozalloc for cstdlib. See bug 1245076.
++#ifndef moz_dont_include_mozalloc_for_cstdlib
++# define moz_dont_include_mozalloc_for_cstdlib
++#endif
++#ifndef moz_dont_include_mozalloc_for_${HEADER}
+ // mozalloc.h wants <new>; break the cycle by always explicitly
+ // including <new> here. NB: this is a tad sneaky. Sez the gcc docs:
+ //
+ // `#include_next' does not distinguish between <file> and "file"
+ // inclusion, nor does it check that the file you specify has the
+ // same name as the current file. It simply looks for the file
+ // named, starting with the directory in the search path after the
+ // one where the current file was found.
+-#include_next <new>
++# include_next <new>
+
+ // See if we're in code that can use mozalloc. NB: this duplicates
+ // code in nscore.h because nscore.h pulls in prtypes.h, and chromium
+ // can't build with that being included before base/basictypes.h.
+-#if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
+-# include "mozilla/mozalloc.h"
+-#else
+-# error "STL code can only be used with infallible ::operator new()"
++# if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
++# include "mozilla/mozalloc.h"
++# else
++# error "STL code can only be used with infallible ::operator new()"
++# endif
++
+ #endif
+
+ #if defined(DEBUG) && !defined(_GLIBCXX_DEBUG)
+ // Enable checked iterators and other goodies
+ //
+ // FIXME/bug 551254: gcc's debug STL implementation requires -frtti.
+ // Figure out how to resolve this with -fno-rtti. Maybe build with
+ // -frtti in DEBUG builds?
diff --git a/community/firefox-esr/mozilla-flexible-array-member-in-union.patch b/community/firefox-esr/mozilla-flexible-array-member-in-union.patch
new file mode 100644
index 00000000000..74530c74989
--- /dev/null
+++ b/community/firefox-esr/mozilla-flexible-array-member-in-union.patch
@@ -0,0 +1,22 @@
+--- firefox-45.0.1-orig/gfx/harfbuzz/src/hb-font-private.hh 2016-03-15 23:37:28.000000000 +0100
++++ firefox-45.0.1/gfx/harfbuzz/src/hb-font-private.hh 2016-05-13 17:20:25.836258108 +0200
+@@ -80,7 +80,7 @@ struct hb_font_funcs_t {
+ HB_FONT_FUNCS_IMPLEMENT_CALLBACKS
+ #undef HB_FONT_FUNC_IMPLEMENT
+ } f;
+- void (*array[]) (void);
++ void (*array[VAR]) (void);
+ } get;
+ };
+
+--- firefox-45.0.1-orig/gfx/harfbuzz/src/hb-private.hh 2016-03-15 23:37:28.000000000 +0100
++++ firefox-45.0.1/gfx/harfbuzz/src/hb-private.hh 2016-05-13 17:20:55.909655179 +0200
+@@ -1010,5 +1010,7 @@ hb_options (void)
+ return _hb_options.opts;
+ }
+
++/* Size signifying variable-sized array */
++#define VAR 1
+
+ #endif /* HB_PRIVATE_HH */
+