aboutsummaryrefslogtreecommitdiffstats
path: root/community/frotz
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2020-07-18 23:20:18 +0300
committerLeo <thinkabit.ukim@gmail.com>2020-07-19 03:45:21 +0000
commit834412e41b6c321b8c7223c57ad1b9865ca03703 (patch)
tree925dafcef0573dbb1f578c2ae23bfba007be472e /community/frotz
parent508de7539866f96eb05d3e918d66fe313b1c6101 (diff)
community/frotz: upgrade to 2.52
* Update source url to new upstream. * Remove uneeded patch and use our own CFLAGS.
Diffstat (limited to 'community/frotz')
-rw-r--r--community/frotz/APKBUILD26
-rw-r--r--community/frotz/Makefile.patch49
2 files changed, 13 insertions, 62 deletions
diff --git a/community/frotz/APKBUILD b/community/frotz/APKBUILD
index 84ef7be19c7..6852182a59a 100644
--- a/community/frotz/APKBUILD
+++ b/community/frotz/APKBUILD
@@ -1,29 +1,29 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=frotz
-pkgver=2.44
-pkgrel=1
+pkgver=2.52
+pkgrel=0
pkgdesc="Portable Z-Machine Interpreter"
url="http://frotz.sourceforge.net/"
arch="all"
license="GPL-2.0-or-later"
-makedepends="ncurses-dev"
+makedepends="libao-dev libmodplug-dev libsamplerate-dev libsndfile-dev
+ ncurses-dev"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/DavidGriffith/frotz/archive/$pkgver.tar.gz
- Makefile.patch
- "
+source="https://gitlab.com/DavidGriffith/frotz/-/archive/$pkgver/frotz-$pkgver.tar.bz2"
+
+prepare() {
+ default_prepare
+ # use our cflags
+ sed -i 's/^CFLAGS +=/CFLAGS ?=/g' Makefile
+}
build() {
make
}
package() {
- strip $pkgname
- install -m755 -d "$pkgdir/usr/bin"
- install -m755 -d "$pkgdir/usr/share/man/man6"
- install -m755 $pkgname "$pkgdir/usr/bin/"
- install -m644 doc/$pkgname.6 $pkgdir/usr/share/man/man6/$pkgname.6
+ make DESTDIR="$pkgdir" PREFIX=/usr install
}
-sha512sums="20b2c8948f093463c53498b322230881aa1ad9c8fd68a338b4f5c4803ab28007fc8ba63f6d20f2b4d440fd04138709b9f4f103c9f8a71788e80156ccdff9ce1f frotz-2.44.tar.gz
-50bd0db62eb09bb316dbab106d2bba0ad389e151fefbc587dbd15faf238b559276ce9d603333d5da8760623d014e2587609b96401e616f22062cb0a6aaa2f346 Makefile.patch"
+sha512sums="387e7a7fe0cffd40b639a306eef89a22421a4ff4a8e5dbcf96a1ef3b901744b3f75a671953ecdc17bde0d699e4756d470b61c8213c47315baa2700da92d06710 frotz-2.52.tar.bz2"
diff --git a/community/frotz/Makefile.patch b/community/frotz/Makefile.patch
deleted file mode 100644
index ead06f88d04..00000000000
--- a/community/frotz/Makefile.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- src/frotz-2.43d/Makefile 2012-01-03 08:32:58.000000000 +0000
-+++ ../Makefile 2014-12-01 13:08:50.390040011 +0000
-@@ -14,19 +14,19 @@
- #-malign-jumps=2
-
- # Define where you want Frotz installed. Usually this is /usr/local
--PREFIX = /usr/local
-+PREFIX = /usr
-
--MAN_PREFIX = $(PREFIX)
--#MAN_PREFIX = /usr/local/share
-+#MAN_PREFIX = $(PREFIX)
-+MAN_PREFIX = /usr/share
-
--CONFIG_DIR = $(PREFIX)/etc
--#CONFIG_DIR = /etc
-+#CONFIG_DIR = $(PREFIX)/etc
-+CONFIG_DIR = /etc
-
- # Define where you want Frotz to look for frotz.conf.
- #
--CONFIG_DIR = /usr/local/etc
--#CONFIG_DIR = /etc
--#CONFIG_DIR = /usr/pkg/etc
-+#CONFIG_DIR = /usr/local/etc
-+#CONFIG_DIR = /etc
-+#CONFIG_DIR = /usr/pkg/etc
- #CONFIG_DIR =
-
- # Uncomment this if you want color support. Most, but not all curses
-@@ -73,15 +73,15 @@
- # curses library won't work, comment out the first option and uncomment
- # the second.
- #
--CURSES = -lcurses
--#CURSES = -lncurses
-+#CURSES = -lcurses
-+CURSES = -lncurses
-
- # Uncomment this if your need to use ncurses instead of the
- # vendor-supplied curses library. This just tells the compile process
- # which header to include, so don't worry if ncurses is all you have
- # (like on Linux). You'll be fine.
- #
--#CURSES_DEF = -DUSE_NCURSES_H
-+CURSES_DEF = -DUSE_NCURSES_H
-
- # Uncomment this if you're compiling Unix Frotz on a machine that lacks
- # the memmove(3) system call. If you don't know what this means, leave it