aboutsummaryrefslogtreecommitdiffstats
path: root/community/fvwm
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2017-04-11 15:32:09 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-25 11:46:05 +0000
commit4856cecfec35fb9de02f0221bea7e33e4f67dd43 (patch)
tree7b161dcf58677fd5da952e82a803381892db8ba5 /community/fvwm
parentb10ec1abf1c211aae19284d697332eed8c902f16 (diff)
community/fvwm: enables check function and minor cleanup
Enables the check function for this build and does a minor clean to bring the APKBUILD syntax up to date.
Diffstat (limited to 'community/fvwm')
-rw-r--r--community/fvwm/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/community/fvwm/APKBUILD b/community/fvwm/APKBUILD
index d9083b58480..891b7f7ca21 100644
--- a/community/fvwm/APKBUILD
+++ b/community/fvwm/APKBUILD
@@ -18,21 +18,23 @@ source="https://github.com/fvwmorg/fvwm/releases/download/$pkgver/$pkgname-$pkgv
builddir=$srcdir/${pkgname}-${pkgver}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--disable-perllib \
--disable-bidi \
--disable-rsvg \
- --disable-xinerama \
- --disable-gtk \
- --with-gnome=no \
- || return 1
+ --disable-xinerama
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="127cd1cc68e98e673056c1dd5108dfabc7560cfc98c86e35b95d75c6327156389f77aa0470e2e6f702865367f29d3bd1cfa8cf07a5b1c1693fa6e04fb2af717f fvwm-2.6.7.tar.gz"