aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-lfs
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-08-25 15:33:24 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-08-25 15:33:50 +0200
commit1cb194a5d48c3ad429bddf3c5129150e55c58974 (patch)
tree8f818ed088827c9ef7c75d785d5e06ac863cc5c1 /community/git-lfs
parent785270d906a3071ef26e1ad77f6ee48d2f495f8d (diff)
community/git-lfs: upgrade to 2.5.1
Diffstat (limited to 'community/git-lfs')
-rw-r--r--community/git-lfs/APKBUILD49
-rw-r--r--community/git-lfs/fix-test-locks.patch4
-rw-r--r--community/git-lfs/makefile-extra_go_flags.patch19
3 files changed, 42 insertions, 30 deletions
diff --git a/community/git-lfs/APKBUILD b/community/git-lfs/APKBUILD
index f6a5b8fd544..ad7bc2f1a18 100644
--- a/community/git-lfs/APKBUILD
+++ b/community/git-lfs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=git-lfs
-pkgver=2.4.2
+pkgver=2.5.1
pkgrel=0
pkgdesc="Git extension for versioning large files"
url="https://git-lfs.github.io/"
@@ -15,10 +15,16 @@ options="!strip"
subpackages="$pkgname-doc"
install="$pkgname.post-install $pkgname.pre-deinstall"
source="$pkgname-$pkgver.tar.gz::https://github.com/git-lfs/$pkgname/archive/v$pkgver.tar.gz
- fix-test-locks.patch"
+ fix-test-locks.patch
+ makefile-extra_go_flags.patch
+ "
builddir="$srcdir/src/github.com/git-lfs/$pkgname"
export GOPATH="$srcdir:$builddir"
+# -tags netcgo - use system's DNS resolver by default. Go's built-in DNS
+# resolver is buggy; it resolved localhost to totally wrong IP
+# address on ARM builders and so caused test failures.
+_goflags="-v -tags netcgo"
prepare() {
mkdir -p "${builddir%/*}"
@@ -30,27 +36,21 @@ prepare() {
build() {
cd "$builddir"
- # Build manpages first (some embedding in the executable is done).
- cd docs
- ronn man/*.ronn
- go run man/mangen.go
- cd -
-
- # Build git-lfs executable.
- _gobuild -o bin/$pkgname
+ make \
+ EXTRA_GO_FLAGS="$_goflags" \
+ GIT_LFS_SHA="v$pkgver" \
+ VERSION="v$pkgver"
+ make man
# Build test executables.
- local file; for file in test/cmd/*.go; do
- _gobuild -o bin/$(basename $file .go) $file
+ local file; for file in t/cmd/*.go; do
+ go build $_goflags -o bin/$(basename $file .go) $file
done
- _gobuild -o bin/git-lfs-test-server-api \
- test/git-lfs-test-server-api/*.go
}
check() {
cd "$builddir"
-
- GIT_LFS_TEST_MAXPROCS=$JOBS SKIPCOMPILE=1 ./script/integration
+ make integration EXTRA_GO_FLAGS="$_goflags"
}
package() {
@@ -62,21 +62,14 @@ package() {
install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
mkdir -p "$mandir"/man1 "$mandir"/man5
- install -m 644 docs/man/*.1 "$mandir"/man1/
- install -m 644 docs/man/*.5 "$mandir"/man5/
+ install -m 644 man/*.1 "$mandir"/man1/
+ install -m 644 man/*.5 "$mandir"/man5/
mkdir -p "$docdir"
cp -r docs/*.md docs/api "$docdir"/
rm -r "$docdir"/api/schemas
}
-_gobuild() {
- # -tags netcgo - use system's DNS resolver by default. Go's built-in DNS
- # resolver is buggy; it resolved localhost to totally wrong IP
- # address on ARM builders and so caused test failures.
- # -ldflags - omit symbol and debug tables (strip).
- go build -tags netcgo -ldflags='-s -w' -v "$@"
-}
-
-sha512sums="c89a15c36b9d52091eb6e89f8e1db23b03f35333794467432ee49728ba83fc5d25d238f5df49bf736a4a3079778d70a527db01c2299ecd96a7b5f70059616967 git-lfs-2.4.2.tar.gz
-66927aa462cb7b5061442e5ffaf7c9e4a5d97179482dc00de3f4abfad5959a9c55df3e88c211067bf15b5b0ea3ef29b249ca32290cc9839280266de5c6854b3f fix-test-locks.patch"
+sha512sums="86b277795ffaba47244f3467e58c1103804f526511c4b0c21566dc05a97eb5d48d0de36f944d906255a8652b9fd698dca4dd50f89d344703b3c6d87117f7fbc1 git-lfs-2.5.1.tar.gz
+8ef31d51ef730d6fbd61e1a839b808a00cacc004b84f3d274c19c47bd2f305bc8173c770573aeb9a454b5ac3ab60947cfaac9b414c51d3bcb857f99ac8de1c41 fix-test-locks.patch
+a66cbf518f15ca59f453ba28407f848aec1f752e3052007abd2196e288a0eef5618fdb1b8ffbad3aaff01bf84efef63d268f7208345e8e6d29c90a1748dd9ffd makefile-extra_go_flags.patch"
diff --git a/community/git-lfs/fix-test-locks.patch b/community/git-lfs/fix-test-locks.patch
index dabbfce8a3d..5e156c9dc94 100644
--- a/community/git-lfs/fix-test-locks.patch
+++ b/community/git-lfs/fix-test-locks.patch
@@ -1,7 +1,7 @@
This is probably a typo. I have no idea why it does not fail for upstream...
---- a/test/test-locks.sh
-+++ b/test/test-locks.sh
+--- a/t/t-locks.sh
++++ b/t/t-locks.sh
@@ -100,7 +100,7 @@
for i in $(seq 1 5); do
diff --git a/community/git-lfs/makefile-extra_go_flags.patch b/community/git-lfs/makefile-extra_go_flags.patch
new file mode 100644
index 00000000000..16e27289066
--- /dev/null
+++ b/community/git-lfs/makefile-extra_go_flags.patch
@@ -0,0 +1,19 @@
+--- a/Makefile
++++ b/Makefile
+@@ -128,7 +128,7 @@
+ # It uses BUILD_MAIN as defined above to specify the entrypoint for building Git
+ # LFS.
+ BUILD = GOOS=$(1) GOARCH=$(2) \
+- $(GO) build \
++ $(GO) build $(EXTRA_GO_FLAGS) \
+ -ldflags="$(LD_FLAGS)" \
+ -gcflags="$(GC_FLAGS)" \
+ -o ./bin/git-lfs$(3) $(BUILD_MAIN)
+--- a/t/Makefile
++++ b/t/Makefile
+@@ -37,4 +37,4 @@
+ $(RM) $(TEST_CMDS)
+
+ ../bin/%$X : cmd/%.go
+- go build -o $@ $^
++ go build $(EXTRA_GO_FLAGS) -o $@ $^