aboutsummaryrefslogtreecommitdiffstats
path: root/community/glib-networking/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:41:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:44:06 +0000
commit1206c1a7e7db1abe4ace99594cb83ff54fd1fd1b (patch)
treef303098ce12a71a8ada0c6d0730df330971452f0 /community/glib-networking/APKBUILD
parent2025b8b36733a490b2a96ec6d49874d0275bf97f (diff)
community/glib-networking: upgrade to 2.56.1
Diffstat (limited to 'community/glib-networking/APKBUILD')
-rw-r--r--community/glib-networking/APKBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/community/glib-networking/APKBUILD b/community/glib-networking/APKBUILD
index 99f89913f7f..6a4351415aa 100644
--- a/community/glib-networking/APKBUILD
+++ b/community/glib-networking/APKBUILD
@@ -1,18 +1,19 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glib-networking
-pkgver=2.54.1
+pkgver=2.56.1
_maj=${pkgver%%.*}
_min=${pkgver#${_maj}.}
_min=${_min%%.*}
_ver=$_maj.$_min
-pkgrel=1
+pkgrel=0
pkgdesc="Networking support for GLib"
url="http://www.gnome.org"
arch="all"
license="LGPL-2.0-or-later"
depends="ca-certificates"
-makedepends="glib-dev gnutls-dev libproxy-dev intltool libgcrypt-dev bash p11-kit-dev"
+makedepends="glib-dev gnutls-dev libproxy-dev intltool libgcrypt-dev bash
+ p11-kit-dev meson gsettings-desktop-schemas-dev"
install=
subpackages="$pkgname-lang"
source="http://download.gnome.org/sources/glib-networking/$_ver/glib-networking-$pkgver.tar.xz"
@@ -20,25 +21,21 @@ options="!check"
build() {
cd "$builddir"
- CONFIG_SHELL=/bin/bash ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
+ --buildtype=release \
--prefix=/usr \
- --disable-more-warnings \
- --with-libproxy \
- --with-gnutls
- make
+ --default-library=shared \
+ . build
+ ninja -C "$builddir"/build
}
check() {
- cd "$builddir"
- make check
+ ninja -C "$builddir"/build test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C "$builddir"/build install
rm -f "$pkgdir"/usr/lib/gio/modules/*.a
}
-sha512sums="8356d835914e33df43f4f2bb6a915ddcd48dd0565e4d5bc1f1d692e9c3124ee4421b99f87f2586f74e9fed24ef7421159f3242fd1eb7bd74950bd25e860896ec glib-networking-2.54.1.tar.xz"
+sha512sums="474d3e334b901c7445a2ee38018a23bbf0a1f4f7403952bf0e1c882f5c9a518b11696d0c69695b3cb378e33e15f619414e46733172ff6564732b96f3c375003d glib-networking-2.56.1.tar.xz"