aboutsummaryrefslogtreecommitdiffstats
path: root/community/glm
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2019-03-18 20:33:09 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-02 19:19:24 +0000
commitf7a8723189832a83c0e6660772ac56f9163d5c81 (patch)
tree1638a236b99191aed31c257b968580dd88d1ffd5 /community/glm
parent5698e9e74f3217e0a58fa9cd8df6fbd48b2869c4 (diff)
commmunity/glm: fix constexpr with GCC
Diffstat (limited to 'community/glm')
-rw-r--r--community/glm/APKBUILD7
-rw-r--r--community/glm/fix-const-expr.patch10
2 files changed, 15 insertions, 2 deletions
diff --git a/community/glm/APKBUILD b/community/glm/APKBUILD
index 798cd5a91ee..738bf0e154e 100644
--- a/community/glm/APKBUILD
+++ b/community/glm/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glm
pkgver=0.9.9.3
-pkgrel=1
+pkgrel=2
pkgdesc="C++ mathematics library for graphics programming"
url="http://glm.g-truc.net/"
arch="noarch"
@@ -10,8 +10,10 @@ makedepends="cmake"
subpackages="$pkgname-dev"
source="https://github.com/g-truc/glm/releases/download/$pkgver/glm-$pkgver.zip
fix-endian-test.patch
+ fix-const-expr.patch
"
builddir="$srcdir/$pkgname"
+patch_args="--binary -p1"
build() {
cd "$builddir"
@@ -36,4 +38,5 @@ package() {
}
sha512sums="eb7589345eb627d9fda84771bd2cf3eb0e4e9e48bf6bb7490bd8844b66558717de5dc96cde9d66e81f7ba4e54090f18dbe1bbccb2452ed0ed8c17cdf7b6e4aa2 glm-0.9.9.3.zip
-54fd8926e3e8271ea32ff25b433003e7eef5611ac7b3c397c0e3b5cd6b139071dba774964c8ae4f8859523a354fec45e38d4ad8fdd46f930f21ce529cc95a65e fix-endian-test.patch"
+54fd8926e3e8271ea32ff25b433003e7eef5611ac7b3c397c0e3b5cd6b139071dba774964c8ae4f8859523a354fec45e38d4ad8fdd46f930f21ce529cc95a65e fix-endian-test.patch
+ef0d6cafbc684f0451b21de82f758480929531dbbce557ace9c9e53f9af65493fe85e1c080f5575efd8da8f0a86dae0cbb0605264d6d58eef1d27db6a6d96e8a fix-const-expr.patch"
diff --git a/community/glm/fix-const-expr.patch b/community/glm/fix-const-expr.patch
new file mode 100644
index 00000000000..c9770369835
--- /dev/null
+++ b/community/glm/fix-const-expr.patch
@@ -0,0 +1,10 @@
+--- a/glm/detail/setup.hpp
++++ b/glm/detail/setup.hpp
+@@ -283,7 +283,6 @@
+ #else
+ # define GLM_HAS_CONSTEXPR ((GLM_LANG & GLM_LANG_CXX0X_FLAG) && GLM_HAS_INITIALIZER_LISTS && (\
+ ((GLM_COMPILER & GLM_COMPILER_INTEL) && (GLM_COMPILER >= GLM_COMPILER_INTEL17)) || \
+- ((GLM_COMPILER & GLM_COMPILER_GCC) && (GLM_COMPILER >= GLM_COMPILER_GCC6)) || \
+ ((GLM_COMPILER & GLM_COMPILER_VC) && (GLM_COMPILER >= GLM_COMPILER_VC15))))
+ #endif
+