aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-software/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-09-01 00:11:20 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-09-07 11:37:26 +0200
commit3e0e30063e992098b94e263ec18b24d011cf26ba (patch)
tree4f5f7e9dedb0f3827227efeda47e09008090bb8b /community/gnome-software/APKBUILD
parent47360782abaf34cd0a1cc746a6bbbaa5966b7515 (diff)
community/gnome-software: use abuild-meson & meson compile/test/install
Diffstat (limited to 'community/gnome-software/APKBUILD')
-rw-r--r--community/gnome-software/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/community/gnome-software/APKBUILD b/community/gnome-software/APKBUILD
index 489a81c3d51..9f82ed31549 100644
--- a/community/gnome-software/APKBUILD
+++ b/community/gnome-software/APKBUILD
@@ -29,26 +29,21 @@ build() {
esac
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
+ abuild-meson \
-Dvalgrind=false \
-Dmalcontent=false \
-Dpackagekit=false \
$conf \
. output
- ninja -C output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
- ninja -C output test
+ meson test --no-rebuild -v -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
flatpak_plugin() {