aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-19 12:06:24 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-19 14:59:44 +0000
commit1db02782e1ed01a3eaeb6a48c7daefeb0ab98bd6 (patch)
treec0f5e526d001deb0ddace703b0938aac753ab0bf /community/gnome/APKBUILD
parent09157d0400f9265cffc3632778e88fc2bdb8c6c4 (diff)
community/gnome: upgrade to 3.36.0
Also add a few new GNOME apps which have been added in the meantime to the -apps subpackage and create the -games-collection subpackage
Diffstat (limited to 'community/gnome/APKBUILD')
-rw-r--r--community/gnome/APKBUILD25
1 files changed, 22 insertions, 3 deletions
diff --git a/community/gnome/APKBUILD b/community/gnome/APKBUILD
index df5258a1d20..f677837fcd7 100644
--- a/community/gnome/APKBUILD
+++ b/community/gnome/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome
-pkgver=3.34.0
-pkgrel=3
+pkgver=3.36.0
+pkgrel=0
pkgdesc="GNOME (Base) meta package"
url="https://www.gnome.org"
arch="x86 x86_64 armv7 aarch64" # GNOME isn't available on all arches yet
@@ -38,7 +38,7 @@ if [ "$CARCH" != "armv7" ]; then
depends="$depends bolt"
fi
-subpackages="$pkgname-apps:_apps"
+subpackages="$pkgname-apps:_apps $pkgname-games-collection:_games"
package() {
mkdir -p "$pkgdir"
@@ -57,6 +57,7 @@ _apps() {
evince
evolution
devhelp
+ easytag
file-roller
fractal
geary
@@ -74,13 +75,17 @@ _apps() {
gnome-clocks
gnome-contacts
gnome-disk-utility
+ gnome-feeds
gnome-games
gnome-latex
gnome-maps
+ gnome-obfuscate
gnome-passwordsafe
gnome-podcasts
gnome-power-manager
gnome-screenshot
+ gnome-shortwave
+ gnome-software
gnome-sound-recorder
gnome-system-monitor
gnome-terminal
@@ -108,6 +113,8 @@ _apps() {
gvfs-avahi
meld
orca
+ peek
+ polari
rhythmbox
nautilus
seahorse
@@ -124,3 +131,15 @@ _apps() {
mkdir -p "$subpkgdir"
}
+
+_games() {
+ depends="
+ aisleriot
+ gnome-2048
+ gnome-chess
+ gnome-taquin
+ lightsoff
+ "
+
+ mkdir -p "$subpkgdir"
+}