aboutsummaryrefslogtreecommitdiffstats
path: root/community/gns3-server
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 12:09:08 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 13:00:04 +0000
commit3291f08e89ce1c33ab9bed491d2bcdbfa572f6af (patch)
tree7f2c044d613d2fd86f1b1583b0311c321c57fe89 /community/gns3-server
parent806a7604e6f4b1247cea0893a411bed20c9efc33 (diff)
community/gns3-server: moved from testing
Diffstat (limited to 'community/gns3-server')
-rw-r--r--community/gns3-server/APKBUILD48
-rw-r--r--community/gns3-server/support-newer-aiohttp-version.patch11
2 files changed, 59 insertions, 0 deletions
diff --git a/community/gns3-server/APKBUILD b/community/gns3-server/APKBUILD
new file mode 100644
index 00000000000..97ce3b89fc9
--- /dev/null
+++ b/community/gns3-server/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=gns3-server
+pkgver=1.5.1
+pkgrel=3
+pkgdesc="GNS3 network simulator. Server package."
+url="https://github.com/GNS3/gns3-server"
+arch="all"
+license="GPL3"
+depends="dynamips python3 py3-psutil py3-jinja2 py3-aiohttp py3-pytest
+ py3-netifaces py3-ws4py py3-zipstream py3-raven py3-jsonschema"
+depends_dev=""
+makedepends="$depends_dev py-setuptools python3-dev linux-headers py3-pytest"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/GNS3/$pkgname/archive/v$pkgver.tar.gz
+ support-newer-aiohttp-version.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
+gns3-server has several optional packages that must be installed manually for additional functionality:
+
+ apk add qemu
+ apk add wiresark
+ apk add ubridge
+ apk add cpulimit
+ apk add iouyap
+ apk add vpcs
+
+EOF
+
+}
+
+md5sums="371d50e3f4e52159620249326a19d0fe gns3-server-1.5.1.tar.gz
+725caa756b2a83f49151d52d1521d534 support-newer-aiohttp-version.patch"
+sha256sums="e871ebe00f2a66876a99c9e71c65afaf74e5d5165c49984033f8599ecf49939e gns3-server-1.5.1.tar.gz
+1da4b7c0758095b67761da0b67c3bc3e82abacfe506e5ccb11f8f0ec3e673b8b support-newer-aiohttp-version.patch"
+sha512sums="fcf5ca0a3bbf5224554c9cecd90a7aded9b658e64eccb778d47ac08c9b4dd567bd757977e8dd54c165d49b24033b99d2b95d5c4892e2b8ad2924d7d3a4c2d9d3 gns3-server-1.5.1.tar.gz
+b6212749460747cf83e189dbdd480e167c70f4f1fbe2df0b419f5503eb375fd0fbdea4467f8fd5e9faa9b42dee1e32b8c13302bd5c66513dca8f6199459a3cdb support-newer-aiohttp-version.patch"
diff --git a/community/gns3-server/support-newer-aiohttp-version.patch b/community/gns3-server/support-newer-aiohttp-version.patch
new file mode 100644
index 00000000000..4711c7c44e4
--- /dev/null
+++ b/community/gns3-server/support-newer-aiohttp-version.patch
@@ -0,0 +1,11 @@
+diff --git a/requirements.txt b/requirements.txt
+index 7fbcea9..59e6145 100644
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -1,5 +1,5 @@
+ jsonschema>=2.4.0
+-aiohttp==0.21.5
++aiohttp>=0.21.5
+ Jinja2>=2.7.3
+ raven>=5.2.0
+ psutil>=3.0.0