aboutsummaryrefslogtreecommitdiffstats
path: root/community/go/APKBUILD
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-11-22 15:03:04 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-19 10:00:36 +0000
commit5b7cc97743791eb2500ca74aa8668964aba10f75 (patch)
treece9ef705710e1b70c986476258d9d00faf4479eb /community/go/APKBUILD
parent75676b1a4e13137d95db1449f3a1456e45180503 (diff)
community/go: fix target float ABI on mips*
Diffstat (limited to 'community/go/APKBUILD')
-rw-r--r--community/go/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 350c226fe6d..72872752d5f 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -54,10 +54,10 @@ s390x) export GOARCH="s390x" ;;
x86) export GOARCH="386" GO386=387 ;;
x86_64) export GOARCH="amd64" ;;
ppc64le) export GOARCH="ppc64le" ;;
-mips) export GOARCH="mips" ;;
-mips64) export GOARCH="mips64" ;;
-mips64el) export GOARCH="mips64le" ;;
-mipsel) export GOARCH="mipsle" ;;
+mips) export GOARCH="mips" GOMIPS=softfloat ;;
+mips64) export GOARCH="mips64" GOMIPS64=softfloat ;;
+mips64el) export GOARCH="mips64le" GOMIPS64=softfloat ;;
+mipsel) export GOARCH="mipsle" GOMIPS=softfloat ;;
*) die "Unsupported arch" ;;
esac