aboutsummaryrefslogtreecommitdiffstats
path: root/community/go/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-08-27 14:30:06 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-04 12:04:20 +0000
commit11c5f257c586b68e3567ece44133b21c02c88f00 (patch)
treea4adc423b5d06a69f1187e761ac7a7387120e158 /community/go/APKBUILD
parent09abdcd67a28428318626eae1eabc5b6448a1e05 (diff)
community/go: remove tools subpackage
According to [0] it is no longer necessary to distribute the tools with the package itself. Additionally, other distributions such as Arch Linux and Void Linux no longer ship the tools with the go package itself. [0]: https://gitlab.informatik.uni-bremen.de/BEDUINO-Master/projektbericht/merge_requests/64#note_118786
Diffstat (limited to 'community/go/APKBUILD')
-rw-r--r--community/go/APKBUILD38
1 files changed, 2 insertions, 36 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index c003624698d..a17d9ea28c8 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -2,10 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=go
pkgver=1.11
-# This should be the latest commit on the corresponding release branch
-# https://github.com/golang/tools/commits/release-branch.go1.10
-_toolsver="e9928cbe4ab476eebf6ff177f77b344773acfa9b"
-pkgrel=1
+pkgrel=2
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
arch="all"
@@ -17,7 +14,6 @@ provides="go-bootstrap=$pkgver-r$pkgrel"
install=""
subpackages="$pkgname-doc"
source="http://golang.org/dl/go${pkgver/_/}.src.tar.gz
- go-tools-${pkgver/_/}-$_toolsver.tar.gz::https://github.com/golang/tools/archive/${_toolsver}.tar.gz
default-buildmode-pie.patch
set-external-linker.patch
"
@@ -32,8 +28,7 @@ source="http://golang.org/dl/go${pkgver/_/}.src.tar.gz
if [ "$CBUILD" = "$CTARGET" ]; then
makedepends="go-bootstrap $makedepends"
provides="go-bootstrap=$pkgver-r$pkgrel"
- subpackages="$subpackages $pkgname-tools"
- _gotools="godoc stringer"
+ subpackages="$subpackages"
else
pkgname="go-bootstrap"
makedepends="go $makedepends"
@@ -44,8 +39,6 @@ else
export LD="${HOSTLD:-ld}"
fi
-_tooldir="$srcdir"/tools-${_toolsver}
-
case "$CTARGET_ARCH" in
aarch64)export GOARCH="arm64" ;;
armhf) export GOARCH="arm" GOARM=6 ;;
@@ -91,13 +84,6 @@ build() {
# FIXME some tests fail:
# PATH="$GOROOT/bin:$PATH" ./run.bash -no-rebuild
-
- mkdir -p "$GOPATH"/src/golang.org/x/tools
- cp -r "$_tooldir"/* "$GOPATH"/src/golang.org/x/tools
-
- for tool in $_gotools; do
- "$GOROOT"/bin/go install golang.org/x/tools/cmd/$tool
- done
}
check() {
@@ -137,26 +123,6 @@ package() {
-exec rm -rf \{\} \+
}
-tools() {
- pkgdesc="Go programming language tools"
- depends="$pkgname"
-
- mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib/go/bin \
- "$subpkgdir"/usr/lib/go/pkg/tool/linux_$GOARCH
-
- for tool in $_gotools; do
- if [ -f "$pkgdir"/usr/lib/go/pkg/tool/linux_$GOARCH/$tool ]; then
- mv "$pkgdir"/usr/lib/go/pkg/tool/linux_$GOARCH/$tool \
- "$subpkgdir"/usr/lib/go/pkg/tool/linux_$GOARCH/$tool
- fi
- if [ -f "$builddir/bin/$tool" ]; then
- install -Dm755 "$builddir/bin/$tool" "$subpkgdir"/usr/lib/go/bin/"$tool"
- ln -s /usr/lib/go/bin/"$tool" "$subpkgdir"/usr/bin/
- fi
- done
-}
-
sha512sums="2758b7924b4b8cffc30b56fbf039b8e23d1a3c42506ed4997bd64531ba742e2c60e95d1fa70cae2ccda45d1959fadccfd2404af87d962530e4b1d3556c4aaf43 go1.11.src.tar.gz
-3b0bf5d4dc60bae92b04b9be9d193a36a35d4abbfce39480a02066ad5557f7529a088b233395c82727e2ebc312aff2fd5e3c9f00cca491e2a8db48e5c31657a4 go-tools-1.11-e9928cbe4ab476eebf6ff177f77b344773acfa9b.tar.gz
a8f3afd97992f03ccf2680cde214eefccac47daeb9eeb689b5e0b206ea3c19cfb23d448a4eb532894d830d4b91cd97b249e88f04c17feba02d9e243b40243bd0 default-buildmode-pie.patch
faf8de430df185842902322f064254f3e9ecee0884b3075b5550c85da15ff61ea6c2bb8d0fb7cf3887abc0e40974bd73ee8f8c14da7f914dde7e9220177c4e2a set-external-linker.patch"