aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authorBrett Buddin <brett@buddin.us>2016-04-20 15:16:16 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-03 20:30:27 +0000
commit8ef571a7581dfffc95a41562134601bfa8a6de8c (patch)
tree2ef0323d94fc4ed07eac10b1095ac51c5c33b414 /community/go
parent3f6c03746a1f4cbd84b8417bcd8e4b2b7c466703 (diff)
community/go: Install time zone database distributed with Go
This fixes time zone lookups using the `time.LoadLocation` function by ensuring that the time zone database distributed with Go ($GOROOT/lib/time/zoneinfo.zip) is installed. You can find more information about this file here: https://golang.org/pkg/time/#LoadLocation
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index a37e1f3c1a7..936f8af097a 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -87,7 +87,7 @@ package() {
# bug (https://github.com/golang/go/issues/2775).
# When this is resolved we can split out the source to a
# go-doc sub package.
- cp -a pkg src "$pkgdir"/usr/lib/go || return 1
+ cp -a pkg src lib "$pkgdir"/usr/lib/go || return 1
cp -r doc misc "$pkgdir"/usr/share/doc/go || return 1
# Remove tests from /usr/lib/go/src.