aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-02-23 16:36:10 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-02-23 16:39:43 +0200
commitb6efdc05ed61dd4c6324852bc67f412cd27fdb61 (patch)
tree34378db0417439fda448ed8f7af6f8fa783b749b /community/go
parentc61da0a01fdaec32c6b9b835723d7f62d794107f (diff)
community/go: provide go-bootstrap
This enables Go to compile itself with previous Go build. Should improve build times. More importantly, this is prerequisite to get the cross compilation makedependencies right. Support for cross-compiling Go to new arches is due out soon.
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 8ff2ae4b254..59ecceb0da7 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -4,7 +4,7 @@ pkgname=go
pkgver=1.7.4
# This should be the latest commit on the corresponding release branch
_toolsver="26c35b4dcf6dfcb924e26828ed9f4d028c5ce05a"
-pkgrel=1
+pkgrel=2
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
arch="all"
@@ -13,6 +13,7 @@ depends="binutils gcc"
depends_dev=""
makedepends="bash"
options="!strip"
+provides="go-bootstrap=$pkgver-r$pkgrel"
install=""
subpackages="$pkgname-doc $pkgname-tools"
source="http://golang.org/dl/go${pkgver/_/}.src.tar.gz