aboutsummaryrefslogtreecommitdiffstats
path: root/community/godep/APKBUILD
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-07-12 02:31:12 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-07-12 00:37:05 +0000
commit4274bdc30e93476e08b4489fe415378b755f6bfb (patch)
treee2bf260b897440db525fd3da8d3aa50e4b656c56 /community/godep/APKBUILD
parent90a0cbcfa1cc699680d9d8efb722702aeb0aa94d (diff)
community/godep: use SPDX license identifier
Diffstat (limited to 'community/godep/APKBUILD')
-rw-r--r--community/godep/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/community/godep/APKBUILD b/community/godep/APKBUILD
index ec81495a38e..43cb742fc8a 100644
--- a/community/godep/APKBUILD
+++ b/community/godep/APKBUILD
@@ -2,36 +2,33 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=godep
pkgver=80
-pkgrel=3
+pkgrel=4
pkgdesc="Dependency tool for go"
url="https://github.com/tools/godep"
arch="all"
-license="BSD"
+license="BSD-3-Clause"
makedepends="go"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/tools/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/src/github.com/tools/$pkgname"
prepare() {
+ default_prepare
mkdir -p "${builddir%/*}"
mv "$srcdir"/$pkgname-$pkgver "$builddir"
-
- default_prepare
}
build() {
- cd "$builddir"
GOPATH="$srcdir" go build
}
check() {
- cd "$builddir"
export EMAIL="Test User <user@example.com>"
GOPATH="$srcdir" go test
}
package() {
- install -D -m 755 "$builddir"/$pkgname "$pkgdir"/usr/bin/godep
+ install -Dm755 "$builddir"/$pkgname "$pkgdir"/usr/bin/godep
}
sha512sums="27e4e3bf746dbfb71aa05e53c5cb2e7eb5ef714d5687739b7a429d699545dc760e4ee90d601091a45239ca3a9827b10957459fb5e647c2b8f3c59fcf6515753b godep-80.tar.gz"