aboutsummaryrefslogtreecommitdiffstats
path: root/community/greenbone-security-assistant
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-26 09:20:54 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-26 09:20:54 +0000
commit1fada8e7fb00c03b64d3db866b4cb6d8eeb5a087 (patch)
treeedc7f860cd3d47ef9d16ca0f7dfe20646516e9e4 /community/greenbone-security-assistant
parent203d9ad1174b6a9e7e680dc6ece6d9e2905ee071 (diff)
community/greenbone-security-assistant: added check() and optional dependencies
Diffstat (limited to 'community/greenbone-security-assistant')
-rw-r--r--community/greenbone-security-assistant/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/community/greenbone-security-assistant/APKBUILD b/community/greenbone-security-assistant/APKBUILD
index 0e4970c1a83..5a8de841fa3 100644
--- a/community/greenbone-security-assistant/APKBUILD
+++ b/community/greenbone-security-assistant/APKBUILD
@@ -4,14 +4,15 @@ pkgname=greenbone-security-assistant
_pkgname=gsad
pkgver=7.0.2
_pkgid=2429
-pkgrel=4
+pkgrel=5
pkgdesc="Greenbone Security Assistant (gsa) - OpenVAS web frontend"
url="http://www.openvas.org/"
arch="all"
license="GPL"
depends="wget"
makedepends="cmake doxygen xmltoman openvas-libraries-dev
- libxslt-dev libmicrohttpd-dev"
+ libxslt-dev libmicrohttpd-dev py-polib"
+checkdepends="cppcheck"
subpackages="$pkgname-doc"
source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz
$_pkgname.initd
@@ -31,7 +32,12 @@ build() {
-DSYSCONFDIR=/etc \
-DSBINDIR=/usr/sbin \
-DLOCALSTATEDIR=/var .
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {