aboutsummaryrefslogtreecommitdiffstats
path: root/community/gst-plugins-bad
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-05-07 16:53:03 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-27 18:45:54 +0000
commit5f55129e178d8f1b89d9ae9b127e13b61a7df1ef (patch)
tree0653f637e2d4099654409074ebe202c0f36d8f1a /community/gst-plugins-bad
parent36a7e5bb77e15947b75926836d9d01382295c29c (diff)
community/gst-plugins-bad: upgrade to 1.16.0
Diffstat (limited to 'community/gst-plugins-bad')
-rw-r--r--community/gst-plugins-bad/APKBUILD80
1 files changed, 21 insertions, 59 deletions
diff --git a/community/gst-plugins-bad/APKBUILD b/community/gst-plugins-bad/APKBUILD
index eb881dd5dcb..8cb0b530c0e 100644
--- a/community/gst-plugins-bad/APKBUILD
+++ b/community/gst-plugins-bad/APKBUILD
@@ -1,80 +1,42 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-bad
-pkgver=1.14.4
-pkgrel=2
-pkgdesc="GStreamer bad plugins"
+pkgver=1.16.0
+pkgrel=0
+pkgdesc="GStreamer streaming media framework bad plug-ins"
url="https://gstreamer.freedesktop.org"
arch="all"
license="GPL-2.0-or-later LGPL-2.0-or-later"
replaces="gst-plugins-bad1"
options="!check" # most fail because: XDG_RUNTIME_DIR not set in the env.
-makedepends="
- alsa-lib-dev
- bluez-dev
- bzip2-dev
- curl-dev
- faac-dev
- faad2-dev
- flite-dev
- glib-dev
- glu-dev
- gsm-dev
- gst-plugins-base-dev
- gstreamer-dev
- libdc1394-dev
- libexif-dev
- libmms-dev
- libmodplug-dev
- openssl-dev
- librsvg-dev
- libvdpau-dev
- libx11-dev
- mesa-dev
- neon-dev
- orc-dev
- directfb-dev
- spandsp-dev
- libwebp-dev
- x265-dev
- libass-dev
- libsrtp-dev
- orc-compiler
- opus-dev
- tiff-dev
- "
-subpackages="$pkgname-lang $pkgname-dev $pkgname-doc"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz"
+makedepends="alsa-lib-dev bluez-dev bzip2-dev curl-dev directfb-dev faac-dev
+ faad2-dev flite-dev glib-dev glu-dev gsm-dev gst-plugins-base-dev
+ gstreamer-dev libass-dev libdc1394-dev libexif-dev libmms-dev
+ libmodplug-dev librsvg-dev libsrtp-dev libvdpau-dev libwebp-dev
+ libx11-dev mesa-dev meson neon-dev openssl-dev opus-dev orc-compiler
+ orc-dev spandsp-dev tiff-dev x265-dev"
+subpackages="$pkgname-lang $pkgname-dev"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/$pkgname-$pkgver.tar.xz"
ldpath="/usr/lib/gstreamer-1.0"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
--sysconfdir=/etc \
+ --mandir=/usr/share/man \
--localstatedir=/var \
- --disable-static \
- --enable-experimental \
- --disable-fatal-warnings \
- --with-package-name="GStreamer Bad Plugins (Alpine Linux)" \
- --with-package-origin="http://alpinelinux.org/"
- make
+ --buildtype=release \
+ -Dpackage-origin="https://alpinelinux.org" \
+ -Dpackage-name="GStreamer bad plug-ins (Alpine Linux)" \
+ . output
+ ninja -C output
}
check() {
- cd "$builddir"
- make check
+ meson test -C output --print-errorlogs
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
-doc() {
- default_doc
- replaces="${pkgname}1-doc"
-}
-
-sha512sums="a5bef1863110ae25ef4c75ad2cdbbde011e1d1a722754cc0372e8de9c81aee9159e2301d90d6f9b04b66a20887abe20de20d74dbe207d20102e8081130eaf839 gst-plugins-bad-1.14.4.tar.xz"
+sha512sums="3555817553392ff258024cd4532252939d3f4cc6755746e3ac74a3327218a7c4a87e33d455fdd58a63fb1d5b4691a164d90e7824558ecf845fd6c77c99181aa2 gst-plugins-bad-1.16.0.tar.xz"