aboutsummaryrefslogtreecommitdiffstats
path: root/community/gst-plugins-good
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-02-26 21:55:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-02-26 22:03:13 +0000
commit031bb937ffb8677ff0038b2c8faf3ed3a56c4a73 (patch)
treec5f78ef994888cf68e19a61acd5db6e634a96987 /community/gst-plugins-good
parentf227c87fc085437b2d1973463cf68e37583232fc (diff)
community/gst-plugins-good: fix build against libvpx 1.8
Diffstat (limited to 'community/gst-plugins-good')
-rw-r--r--community/gst-plugins-good/APKBUILD10
-rw-r--r--community/gst-plugins-good/libvpx-1.8.patch62
2 files changed, 69 insertions, 3 deletions
diff --git a/community/gst-plugins-good/APKBUILD b/community/gst-plugins-good/APKBUILD
index 6de4e9f70e0..f7fa7c8caa7 100644
--- a/community/gst-plugins-good/APKBUILD
+++ b/community/gst-plugins-good/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-good
pkgver=1.14.4
-pkgrel=1
+pkgrel=2
pkgdesc="GStreamer Multimedia Framework Good Plugins"
url="https://gstreamer.freedesktop.org"
arch="all"
@@ -9,6 +9,7 @@ license="GPL-2.0-or-later LGPL-2.0-or-later"
subpackages="$pkgname-lang $pkgname-doc $pkgname-qt $pkgname-gtk"
replaces="gst-plugins-good1"
makedepends="
+ libtool automake autoconf
gstreamer-dev
gst-plugins-base-dev
flac-dev
@@ -46,7 +47,8 @@ makedepends="
orc-compiler
"
ldpath="/usr/lib/gstreamer-1.0"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz
+ libvpx-1.8.patch"
options="!check" # elements/souphttpsrc fails
# secfixes:
@@ -63,6 +65,7 @@ options="!check" # elements/souphttpsrc fails
build() {
cd "$builddir"
+ autoreconf -vif
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -116,4 +119,5 @@ doc() {
replaces="${pkgname}1-doc"
}
-sha512sums="30aeb3bb74571287cad1598973da38e7a43a0128d35480ded6d280c1373dc4ecd4ea76caaa04a71cdfba2e1850aee5f1b72d96be86ae92d66633e7d32081c504 gst-plugins-good-1.14.4.tar.xz"
+sha512sums="30aeb3bb74571287cad1598973da38e7a43a0128d35480ded6d280c1373dc4ecd4ea76caaa04a71cdfba2e1850aee5f1b72d96be86ae92d66633e7d32081c504 gst-plugins-good-1.14.4.tar.xz
+e0bcc742ae1a42e4423e5cd7d509508c45b699d1625eb5666a8248825c7a69d557e288060bc5e44b195358b660e4cc5afe8ca66ef22f0ae6f6268f6475143d1a libvpx-1.8.patch"
diff --git a/community/gst-plugins-good/libvpx-1.8.patch b/community/gst-plugins-good/libvpx-1.8.patch
new file mode 100644
index 00000000000..9cd3a9329da
--- /dev/null
+++ b/community/gst-plugins-good/libvpx-1.8.patch
@@ -0,0 +1,62 @@
+From b6e6f1ae73375ef66a5748069843aaed1a83e6a6 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Tue, 5 Feb 2019 22:14:18 +0100
+Subject: [PATCH] vpx: Fix build against libvpx 1.8
+
+The deprecated debug visualizer was removed.
+---
+ configure.ac | 4 ++++
+ ext/vpx/gstvpxdec.c | 2 ++
+ ext/vpx/meson.build | 4 ++++
+ 3 files changed, 10 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 5e4cff126..8c20e5081 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1054,6 +1054,10 @@ AG_GST_CHECK_FEATURE(VPX, [VPX decoder], vpx, [
+ AC_DEFINE(HAVE_VPX_1_4, 1, [Defined if the VPX library version is 1.4 or bigger])
+ ], [true])
+
++ PKG_CHECK_MODULES(VPX_180, vpx >= 1.8.0, [
++ AC_DEFINE(HAVE_VPX_1_8, 1, [Defined if the VPX library version is 1.8 or bigger])
++ ], [true])
++
+ LIBS="$OLD_LIBS"
+ CFLAGS="$OLD_CFLAGS"
+ fi
+diff --git a/ext/vpx/gstvpxdec.c b/ext/vpx/gstvpxdec.c
+index c3f0f625f..da4322513 100644
+--- a/ext/vpx/gstvpxdec.c
++++ b/ext/vpx/gstvpxdec.c
+@@ -62,6 +62,7 @@ gst_vpx_dec_post_processing_flags_get_type (void)
+ {C_FLAGS (VP8_DEBLOCK), "Deblock", "deblock"},
+ {C_FLAGS (VP8_DEMACROBLOCK), "Demacroblock", "demacroblock"},
+ {C_FLAGS (VP8_ADDNOISE), "Add noise", "addnoise"},
++#ifndef HAVE_VPX_1_8
+ {C_FLAGS (VP8_DEBUG_TXT_FRAME_INFO),
+ "Print frame information",
+ "visualize-frame-info"},
+@@ -74,6 +75,7 @@ gst_vpx_dec_post_processing_flags_get_type (void)
+ {C_FLAGS (VP8_DEBUG_TXT_RATE_INFO),
+ "Print video rate info",
+ "visualize-rate-info"},
++#endif
+ {C_FLAGS (VP8_MFQE), "Multi-frame quality enhancement", "mfqe"},
+ {0, NULL, NULL}
+ };
+diff --git a/ext/vpx/meson.build b/ext/vpx/meson.build
+index 6ed440728..0d2340b32 100644
+--- a/ext/vpx/meson.build
++++ b/ext/vpx/meson.build
+@@ -48,6 +48,10 @@ if vpx_dep.found()
+ vpx_args += '-DHAVE_VPX_1_4'
+ endif
+
++ if dependency('vpx', version : '>=1.8.0', required : false).found()
++ vpx_args += '-DHAVE_VPX_1_8'
++ endif
++
+ gstvpx = library('gstvpx',
+ vpx_sources,
+ c_args : gst_plugins_good_args + vpx_args,