aboutsummaryrefslogtreecommitdiffstats
path: root/community/heirloom-doctools
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-12 07:58:42 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 08:21:20 -0300
commit9c8052ec4d6811a24ad0ee5d80f468de5fae4dc3 (patch)
treeb46b38a69c7d642695cbad33efd2624a8e987cc2 /community/heirloom-doctools
parent5d67f72060818f35b3f8b817b57d1596f9593f6c (diff)
community/heirloom-doctools: upgrade to 191015
Diffstat (limited to 'community/heirloom-doctools')
-rw-r--r--community/heirloom-doctools/APKBUILD15
-rw-r--r--community/heirloom-doctools/fix-bison-parsing.patch11
2 files changed, 6 insertions, 20 deletions
diff --git a/community/heirloom-doctools/APKBUILD b/community/heirloom-doctools/APKBUILD
index 93e068ee9c6..54659791428 100644
--- a/community/heirloom-doctools/APKBUILD
+++ b/community/heirloom-doctools/APKBUILD
@@ -1,18 +1,16 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=heirloom-doctools
-pkgver=160308
-pkgrel=7
+pkgver=191015
+pkgrel=0
pkgdesc="The Heirloom Documentation Tools"
url="http://n-t-roff.github.io/heirloom/doctools.html"
arch="all"
license="CDDL"
depends="!coreutils !util-linux !mdocml-soelim"
-depends_dev=""
makedepends="flex bison"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/n-t-roff/${pkgname}/archive/${pkgver}.tar.gz
- fix-bison-parsing.patch"
+source="heirloom-doctools-$pkgver.tar.gz::https://github.com/n-t-roff/heirloom-doctools/archive/$pkgver.tar.gz"
_makeargs="
CC="${CC:-gcc}" \
@@ -35,17 +33,16 @@ _makeargs="
build() {
# Unfortunately parallel build isn't supported.
- make -j1 $_makeargs -C "$builddir" || return 1
+ make -j1 $_makeargs -C "$builddir"
}
package() {
# Unfortunately parallel install isn't supported.
make -j1 ROOT="$pkgdir" $_makeargs \
- -C "$builddir" install || return 1
+ -C "$builddir" install
# Don't conflict with mdocml-doc
rm -f "$pkgdir"/usr/share/man/man1/soelim.1
}
-sha512sums="46a5b2969a807abeb4a45eb63db918c903fe02226edddccabc4eabc7e6ad77dd1c0cf633fe55981f16907cb96f3a94a769383966d2f5f5dcde276734f7ad00d7 heirloom-doctools-160308.tar.gz
-fd3bf026749d960c63e3a0b8dbb66c7aa1035f4a314a256e7b8794336b48901452fce6a78b54daf4a5eaf909ef27759c1e58ec59391af75bf083e54a2da7b138 fix-bison-parsing.patch"
+sha512sums="60fd531c29edc7ecee479b69111effa30555c6ba93de3aa4c9f3f06d50a504848eaf800f8fd39865f83d6ed73c03b14e1a416bf942ba82f8a4211344002ad179 heirloom-doctools-191015.tar.gz"
diff --git a/community/heirloom-doctools/fix-bison-parsing.patch b/community/heirloom-doctools/fix-bison-parsing.patch
deleted file mode 100644
index 40d440256a9..00000000000
--- a/community/heirloom-doctools/fix-bison-parsing.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/eqn/yyval.sed
-+++ b/eqn/yyval.sed
-@@ -7,7 +7,7 @@
- 1,2 {
- /Bison/ {
- :look
-- /second part of user declarations/ {
-+ /^#ifdef YYTYPE_UINT8$/ {
- i\
- YYSTYPE yyval;
- :repl