aboutsummaryrefslogtreecommitdiffstats
path: root/community/hivex
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-09-20 22:57:55 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-09-20 22:57:55 +0000
commit76d48c17561039f2420266cf30cc71a499d725a5 (patch)
tree984d66ad28e8288d78eb34dcc5fb9147f4f59c1a /community/hivex
parentf367fd38c3d1e08429c3b2090ea5c7c1a0dcbd7c (diff)
community/hivex: modernize and add check
Diffstat (limited to 'community/hivex')
-rw-r--r--community/hivex/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/hivex/APKBUILD b/community/hivex/APKBUILD
index 83d0777b9c7..b7f3ef52cd6 100644
--- a/community/hivex/APKBUILD
+++ b/community/hivex/APKBUILD
@@ -2,20 +2,20 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=hivex
pkgver=1.3.14
-pkgrel=1
+pkgrel=2
pkgdesc="System for extracting the contents of Windows Registry."
url="http://libguestfs.org"
arch="all"
license="LGPL2.1"
-depends=""
makedepends="python2-dev libxml2-dev readline-dev perl-dev"
+checkdepends="bash"
subpackages="$pkgname-dev $pkgname-doc"
source="http://libguestfs.org/download/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- ./configure \
+ ./configure \
--bindir=/usr/bin \
--libdir=/usr/lib \
--prefix=/usr \
@@ -24,7 +24,12 @@ build() {
--disable-ruby \
--disable-ocaml \
--disable-static
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {