aboutsummaryrefslogtreecommitdiffstats
path: root/community/ices
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-23 06:47:50 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-23 06:47:50 +0000
commit3adb5011329254bf62a3b422ae7cf3509ad930bd (patch)
tree75aa0c59a7db3f79f69fa026eb32ca13befbcefa /community/ices
parentcaa15d2108a8e07649805f32784da705ed7761a6 (diff)
community/ices: moved from testing
Diffstat (limited to 'community/ices')
-rw-r--r--community/ices/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/ices/APKBUILD b/community/ices/APKBUILD
new file mode 100644
index 00000000000..5ab8f1584dd
--- /dev/null
+++ b/community/ices/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ices
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="Source client for broadcasting in MP3 format to an icecast2 server"
+url="http://icecast.org/ices.php"
+arch="all"
+license="GPL2+"
+depends=""
+makedepends="libogg-dev libxml2-dev libvorbis-dev libshout-dev alsa-lib-dev
+ lame-dev perl-dev python2-dev libxml2-dev linux-headers"
+subpackages="$pkgname-doc"
+source="http://downloads.us.xiph.org/releases/ices/$pkgname-$pkgver.tar.gz"
+
+builddir=$srcdir/$pkgname-$pkgver
+
+prepare() {
+ default_prepare || return 1
+ update_config_guess || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/share/doc/ \
+ --with-lame \
+ --with-vorbis \
+ --with-python \
+ --with-perl \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ make -C conf DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="d2f53320ebc7b468d0e0f8a3d2b70883 ices-2.0.2.tar.gz"
+sha256sums="7bf7a9c5bce1b6465df8dd1491e303544990006b8ef01f8ba8eeb38844588859 ices-2.0.2.tar.gz"
+sha512sums="b8d55e4cb7498576aec42c69cea6410e4fc0b2ffb8559575b35b8cb7857b769dbb5633ac206eebd74068bbbac60b4642847c9b261786463e1c46b8930add3d1b ices-2.0.2.tar.gz"